App not installed error while updating app

You are wrongly suspecting the issue. You think i have multiple accounts and i forgot through which of them i have uploaded app.
I have only one account.
Let me again briefly clear you the issue.
I created first app with keys, say ABC, and hosted in playstore. I created update of app and replaced previous app with new built whose keys were also, say ABC. When i tried after some days to update third version, it was not updating because keys were different. I checked the installed app on my phone with last updated version on playstore and when analysed using third party app found key to be XYZ instead of ABC

I do not understand what your friend and his account has to do with the matter.

So again the question: Which Kodular account and which Google Play Console were used for the releases in the Play Store.

My kodular and his google play account

And every time you did a Play Store update, you sent your friend the APK you created. Is that correct?

Yes, i have already said that in example

No, you said:

So your friend - and not you - did the update (uploaded to Play Store) and obviously the error is on his side. Maybe he has enabled “Google app signing”.

Third version has not been uploaded to playstore. After giving output, i was updating it on my phone directly, to test if everything is fine.

Try this:

  1. Uninstall your app from your device.
  2. Take the first APK (your first release version, but not from PlayStore) and install it.
  3. Now install the second and after that the third.
    Are there any problems? I don’t think so.

Then ask your friend to download the first, 2. and 3. release from his Google Console and send it to you. The names should be: 1.apk, 2.apk, 3.apk.

Now unistall your app again, install 1.apk and then try to update with your APKs (that you have saved on you PC).

Then we’ll see …

Which apks? Given by friend or mine?

Your own, the ones you sent him.

Installation was successful without any error
I removed current app. Then installed first version of app from playstore, then updated it with second release of playstore and finally updated it with current(last) apk which is in my pc and has not been sent to playstore.

Which of the two statements is correct now?

Quite obviously, the last one

This is far from obvious and makes no sense at all. Read your own statements.

That is why this problem has been posted in this forum. If you think i am lying i can give you app link and latest apk. I tried on other phone too, still same issue.

Probably, there is a setting in playstore which automatically re-singns app, which is causing this issue

Maybe, but I don’t think so. However, ask your friend that he gives you access to your own app in his Play Console, then you can upload it yourself.

Problem is with published apo, not with raw APK, so it does not matter if i upload or he. Moreover, i searched on google and found steps to stop app signing by google, i have sent him steps, lets see what happens now. In order to to confirm more of this issue, i will check his other apps to see their signature, if they matches, it means google is signing app.

However, he has to manually activate Google App Signing. And he said he didn’t. To make sure that it is always best to do everything yourself.