Blocks are not Loaded - for unchanged apps, even old versions


I read a few posts on the problem with “The blocks area did not load properly. Changes to the blocks for screen xxxx will not be saved.”, and it seems solutions are quite elaborate, and also involves assumptions about either extensions being used, or specific blocks being the culprits.

My problem is that I am opening kodular for the first time in months, and my already released versions of apps (many versions, and backups as well) behave like this. I.e. both the most recent version, and previous versions, of my apps have this issue. So I sort of assume that is it not my changes that causes the problem, but that something I did long ago that is no longer accepted, due to changes in the platform. Actually, ALL the backups I have of this app have the same issue.

The screen as such is (luckily) trivial, as it is the start screen with pretty much only some text and a start and a quit button on it. So i hop I can recreate it (although there may be references back to it that will break, obviously). But how do I get out of this error situation? If I remove the screen, and insert a new one, will things be fine, e.g.? And what is going on, anyway? What is the actual error? And why does it appear like this on all old versions?

Manual editing of an AIA file seems a long detour to solve this.

Most probably you have an empty slot in open another screen block, see how to fix it

Thanks, but i am not sure i understand.

I logged in to kodular for the first time in months, and only opened my project, and was met by this error. Not a single click anywhere. And the project worked when i last used it.

Same with all old backups of the same project. That one screen is said to be erroneous in all of them.

What do you mean with “empty slot” anyway?

If you have “forgotten / left” a block like this


Then download aia, open archive, locate problematic screen’s bky file and edit it. Scroll down and replace ya-version="230" language-version="32" with ya-version="241" language-version="34"

So ia Kodular changed to react like that, making all my backups suddenly not possible to open?

As i said, the projectvhas not been touched, and worked across a number ov versions, which now all behave like this.

Also, i ask again: can i just remove that screen, and just create a new one? Manually editing the aia file for a screen i have not toched since last year to open and correct a minor thing in anotherwise working app is just not making sense from an effort point of view.

If you wish post here your aia or pm me to give a look

Thanks, but that is not the point. I want to know if something has changed that makes Kodular not accept what it accepted before. As i said, i have this problem with a whole bunch of projects (versions of the same project), that all worked back in March. And earlier. Something causes it, and i do not want that to happen again.

The theory on “empty slots” sound like what used to give warnings before now creates unloadable projects. And i note in other (unfinished) projects that i have “empty slots”, and I find it very strange that they would result in errors. How do youcreate anyting without some times having an empty slot, by definition? And with autosave, it would be saved. I cannot see that it would result in unloadable projects?

It turns out that removing screen1 and replacing it with a new one is not an obvious solution, as I am not sure where my app will start if i remove the start screen.

So, I tried your suggestion, to the best of my understanding, but get “The selected project is not a project source file! Project source files are aia files”

What I did:

  • Export AIA
  • Extract with 7-Zip
  • modified per your suggestion (using Notepad)
  • create archive (using zip, not 7z) with 7-Zip (naming it .aia in the process)
  • import to
  • Result: “The selected project is not a project source file! Project source files are aia files”

I tried just extracting and re-creating (with 7-Zip) an archive without any changes to the files, and the result is the same .So the cretaed archive seems not recognized as an AIA file. I note size is 90kB; the original one was 89kB, so they are obviously not identical.

I tried using Windows “compress”, but same result.

What am I doing wrong? Anything in how the archive is created that needs to be specific?

Ah, how stupid Iam. The new AIA i created had a top level folder with the three AIA folders in it, instead of the three AIA folders on the top level… Now it worked! Thanks!

What remains now is to understand what this is all about? Have all my old files been declared “bad” because i had open slots in them, and left them lying around over one or more Kodular updates?

1 Like

This is a bug - open another screen with empty slot - with latest release 1.5.4. Also there is a bug reported regarding colors and one that generates AAPT errors on building apk, both related to project settings . Kodular announced an update on the end June and hopefully all those bugs will be fixed. The only way for now to deal with them in most cases is to edit aia