Bug on WriteExternalStorage Permission - Not Working

Taifun, I changed the Manifest as Anke taught, and now it works.

I Replaced line
uses-permission android:maxSdkVersion="29" android:name="android.permission.WRITE_EXTERNAL_STORAGE"/
uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE"/ .

Now the question is: How to change the aab manifest??

You don’t need to modify aab manifest Convert apk to aab now

first download the apk from https://github.com/sensei-z/APK2AAB/raw/main/Android-Tool/APK2AAB.apk

This apk is developed by @Shreyaa and its very good. I used it personally.

Here is an video

Also there are 2 questions regarding this

  1. Now its working fine in all android version also can you please share your permission blocks.

  2. Also do you use that bodymindpower extension to declare permission in manifest?


Yes, I do it

I used apk2aab and was able to generate the aab file.

But I couldn’t install the package.

Do I need to use ZipSigner too?

In the video I didn’t understand what it’s for (I don’t understand this language).

If I need to use it, where can I find the package to install?

I couldn’t find it on the play store

Thanks in advance

Yes you have to install the android key in that aab.

Download key from Kodular - Preference- Export key

ok. Now i have the keystore exported from kodular.

do you have the zipsigner apk?

AABSigner.apk (1.1 MB)

Here is the apk

4 posts were merged into an existing topic: Firebase authentication not working in Android 11+

Tnx a lot, @Yash_Agarwal

1 Like

Hello everyone!

I tried to use APK2ABB but it doesn’t work with my Apk.

Do you know of any other option? I need to convert my Apk with its new manifest to Aab to upload my update to Googleplay.


Hi can you share with us the code blocks, please I am also having a problem with external storage but I tried this app and it works. this app