Can't save image from crop view extension

Show us what you have tried

In the screen initialise block you ask Read permission. And then in the permission granted block you ask write permission and try. Permission problem only in your app

i did that , but not working , i just need to crop any image to 1080*1080 px :frowning:

Permission granted block will be in yellow. Check it under your screen name

I have tried with these blocks and works fine…
1. Blocks section

2. App Response as per the above blocks
(i painted on personal informations, sorry for that)

Here i have used three labels
In label1 - Name of the image
In Label 2 - Saved image path url
In label 3 - If error occur with crop view
( for cross check i used, while compiling i will remove all the label and you do too)

3. Image stored in phone memory


Here you can use tinyDB to give number. If not cropped image will overwrite in the existing image

4. Image details

Please try like this, and still error persist please ask here. IF it solves, please dont forget to hit solution icon. :wink:

2 Likes

i tried that now , and same problem :frowning:

but i went to apps permission and found that the write permission not found

then i tried this blocks

and this the results when i open the app

thx for your try :heart::heart:

Android version

You are trying in app or companion mode?

Companion means, go to apps>companion> clear all the data. Then try… and your mobile version?

Btw guys, you don’t need to ask for read permission if are asking for write, read will be granted automatically…

1 Like

Yeah mam… actually he tried with write permission only but still he is suffering with same problem.

1 Like

my Android version is 8

I’m using app not companion

yes exactly

Try with companion mode, if it is working mean need to change something

ok i will download firefox now

Also change the existing path URL with this one
/mnt/sdcard/ and try.

I have found the guide for you.

Suppose if the above storage path also says error refer the guide
Also external storage doesn’t work try with internal storage permission

the same blocks worked on companion :grin:

but on app don’t work :frowning: