Cant upload app in playstore target api minimum now api 30

cant upload app in playstore target api minimum now api 30
kodular highest API is only 29

8 Likes
4 Likes

I’m only wondering why the wait for Target API 30?

1 Like

The answer is that many will need every minute until then (Aug 2021) to publish urgent updates with targetSdkVersion = 29. I know from many years of personal experience that I published many updates for my apps shortly before the introduction of a new mandatory API level (or a new minimum iOS version for Apple) in order to escape the increasingly strict storage restrictions (for the time being).

The changes caused by targetSdkVersion = 30 (scoped storage) from Aug 2021 (Nov 2021 for updates) are huge and, in my opinion, represent the biggest (and worst) change that has ever been made to Android / Play Store.

Btw, how the judgment / feedback of the users turns out, I don’t have to explain further … devastating.

1 Like

Ok, hope to solve it as early as it can be.
Thanks.

3 Likes

The requirement has been public for weeks, if not months. There were weeks to get ready for when it actually is in effect, there were even extension(s) made months ago to implement scoped storage.

3 Likes

Yes, but are you not like most (including me) that unpleasant things are postponed until the end?

2 Likes

When it will be updated to API 30 please?

8 Likes

End of the month finished, API 30 ready now?

5 Likes

You should read other topics before asking. This is already answered so i close this.

4 Likes