Change an image but remains in memory

Hi everyone!
I have a yoga practice app. It has the images of the yoga asanas (poses). One of them was wrong, so I made a little procedure to download the right one and overwrite the wrong one, and it works fine.

But to choose the asana the app shows a list view with images, and in this list view remains the old image.
If you select the asana, the new one, the correct one, will appear in the sesion, but in the list view I don’t know why remains the old one.

I guess the images are stored in some kind of cache or memory or something, but I don’t know where and how to delete it or generate it again.
I restarted the device, but the old image remains too.

Any idea?
Thanks in advance!

EDIT:
I used this block after successful download of the image:
imagen
but the old image remains.

I deleted the app’s cache in the app management of the device and then the old image dissapeared, so the problem is the cache but I’m not using the block properly.
How should I use it?

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select “Download Blocks as Image”. You might want to use an image editor to crop etc. if required. Then post it here in the community.

Taifun

Sorry, but “download block as png” and “download block as image” doesn’t work for me, I use Firefox. I’ll try later with another browser.
What I’m doing is download the correct image from Firebase Storage:


And when it is downloaded, a value is storaged so the procedure doesn’t run again and notification is showed:

I tried to clear the cache with your tool, but it seems that it doesn’t work because the old image keep appearing.
I deleted the cache with the app manager in settings and the old image disappeared so I think I’m not using the ClearCache block correctly.
Thanks for your answer.

please show us the blocks of the listview with images
Taifun

This is the procedure that load the asanas, grouped by type or all of them, depending on the user choice:

Listview with images is in another screen. Is that relevant for clearing the cache?

My suggestion is to create a small test project as simple as possible and try to replace an image there
Probably this helps to find the issue
Taifun

Thanks Taifun.

I tried again with a small test project but the problem is the same, the cache has to be deleted.

I tried this:


And the notification appears, so the cache folder is empty, but the old image remains.
If the cache is cleared with the app’s management the new image appears.

Maybe is it another folder what have to be deleted or removed?

Well, I used @Taifun delete cache block this way:
imagen
and this time it worked!
Thanks!

1 Like