[Deprecated] Avoid Crashes of the Application for some of the components

Please include Web viewer also because I created 5 project to check it and in every project it crashes

2 Likes

When Kodular is going to release a update to fix these bugs ?

2 Likes

how you fix it?

1 Like

I donot know

I really stpped while using html string sending to WebView because of do many crash and don’t know what to do

try this. I am also trying. let’s see

1 Like

Hi,

I am sure many are waiting for Kodular fixes for App crashes just like me.

I found a way to FIX issues manually in a bit easier way. I have tried it earlier going through the blocks for hours and still the app would crash after compiling. Other debugging tool was too complex for me :slight_smile: to understand (not a java expert).

Just to describe how complex one of my app is. I have around 9 screens. And one of the main screen has over 5k blocks.

Here is how I fixed it.

Step1 - export your project as aia

Step2 - go to https://unchive.kodular.io/. (Very handy tool. Helps in solving broken project too.)

Step3 - Upload your project. Wait for the project to load. Once loaded, the app details should show in a organised manner.

Step4 - Start scanning properties only (ignore blocks for now) Screen by Screen. Component by component espcially the ones listed in this topic above

Step5 - Fix the properties in creator as you find the issues. (took me actually few mins to find the root cause)

Step6 - Once you have gone through all component properties. Fix the blocks issues accordingly which may take longer depending on how you have coded. For me, not much change other than the webviewer issues.

My major problem was WebViewer Load HTML issue. Was able to solve it using ExtendedWebViewer extension.

I know it is not the best way to fix the issues. But, it worked for me.

Hope this helps someone with their app crashes. Do let me know how it goes.

Kodular team - Thank you for giving an awesome platform to code. I know and understand, some bugs are difficult to fix. But, keep up the good work. I know it is only going to improve from here.

Thanks
Mohan
PS: Please ignore the typos.

7 Likes

Thanks for the solution contribution
I will try to check extended WebView to see my html at WebView bug will solve

2 Likes

Thank you
but now i used unchive.kodular.io load my aia but i can not find where to scan the properties
may please advise how to ?

2 posts were merged into an existing topic: Build server busy please try again later

thank you very much my big problem is solved

1 Like

Click on each container component to view components within it and its properties will show on right.

Thank you I Will try it

This app works normally on the phone emulator, but it crashes when I download it to the phone.
The following is the error information of the Google play test report.
Can anyone tell me what went wrong!

FATAL EXCEPTION: main
Process: io.kodular.app97204.Hi_EV3, PID: 20762
java.lang.RuntimeException: Unable to start activity ComponentInfo{io.kodular.app97204.Hi_EV3/io.kodular.app97204.Hi_EV3.Screen1}: /tmp/1636897566444_0.4775395744126023-0/youngandroidproject/…/src/io/kodular/app97204/Hi_EV3/Screen1.yail:11:78: unbound location null
at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2951)
at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:3086)
at android.app.servertransaction.LaunchActivityItem.execute(LaunchActivityItem.java:78)
at android.app.servertransaction.TransactionExecutor.executeCallbacks(TransactionExecutor.java:108)
at android.app.servertransaction.TransactionExecutor.execute(TransactionExecutor.java:68)
at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1816)
at android.os.Handler.dispatchMessage(Handler.java:106)
at android.os.Looper.loop(Looper.java:193)
at android.app.ActivityThread.main(ActivityThread.java:6718)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:493)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:858)
Caused by: /tmp/1636897566444_0.4775395744126023-0/youngandroidproject/…/src/io/kodular/app97204/Hi_EV3/Screen1.yail:11:78: unbound location null
at gnu.mapping.Location.get(Location.java:67)
at io.kodular.app97204.Hi_EV3.Screen1.lambda4(Screen1.yail:11)
at io.kodular.app97204.Hi_EV3.Screen1$frame.apply0(Screen1.yail:523)
at gnu.expr.ModuleMethod.apply0(ModuleMethod.java:186)
at kawa.lang.Promise.force(Promise.java:27)
at kawa.lang.Promise.force(Promise.java:37)
at kawa.lib.misc.force(misc.scm:98)
at io.kodular.app97204.Hi_EV3.Screen1.$define(Screen1.yail:10307)
at com.google.appinventor.components.runtime.Form.onCreateFinish2(SourceFile:503)
at com.google.appinventor.components.runtime.Form.onCreateFinish(SourceFile:447)
at com.google.appinventor.components.runtime.Form.onCreate(SourceFile:377)
at android.app.Activity.performCreate(Activity.java:7144)
at android.app.Activity.performCreate(Activity.java:7135)
at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1271)
at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2931)
… 11 more

Something is empty in Screen1, check About Screen Title and if this isn’t empty the scroll go through list in post1

3 Likes

Hi folks… i just encountered app freezes at the opening of my app just a week a go. I’m using web view. The weird thing is, when i use the previous apk the problem occur too. So it seems not related to kodular update or any component. I have open the web page on Chrome mobile or desktop and it works normally… I still can’t figure out what’s the problem… Please help…

Will these bugs still be fixed before targetSdkVersion = 31 becomes mandatory? (Probably in a few months …)

See also here:

https://community.appinventor.mit.edu/t/android-12-migration/45926/4?u=anke

2 Likes

Oh sorry, this link was from the AI2 power user forum (only visible for PUs).

So here is a screenshot of it (and the mentioned → blog):

When I try to access https://unchive.kodular.io, it says 182.79.218.34 refused to connect?

Works fine for me

1 Like