[Deprecated] Avoid Crashes of the Application for some of the components

Alright, it did not even after trying on different laptop. I then downloaded it from GITHUB and using is locally. Now, next step is to figure out what component I need to fix to fix app in playstore. Will update if I succeed.

Meanwhile eagerly waiting for this bug to be fixed.

Is there a way we can compile the app on Eagle?

This post was flagged by the community and is temporarily hidden.

Thank you so much for this post, it helps a lot :clap:


This is a very good topic for newcomers to kodular to fix crashes of app!

1 Like

happy christmas!

1 Like

Hello Kodular community,
My app still crashes when i open it. I have done everything which are given above but it didn’t solved yet.
So, Plz can you all suggest some to solve it

I have only this blocks in Screen1
Screenshot 2022-01-09 at 8.37.44 AM

Thanks for the post, it served me a lot!

1 Like

Thanks for the post… due to download component my app was crashing now its working properly.

1 Like

Hello coders

I would like to present here the behavior I have observed.

I made a larger chat app.

When I pressed the home button in the main screen, the application ended the app as requested:

If I then wanted to start the app again, the app flashed (almost always) briefly and then closed again. The app only opened the second time you clicked it.

Now I’ve removed the “Close Application” command and I haven’t observed the behavior anymore.

does anyone know the problem? What could it be?
I have checked all the measures described here and corrected them if necessary.

Do I have the following extensions installed?
Could it be one of them?

I believe your problem is same as the below topic,
Please refer :point_down:

1 Like

Hi i have a problem
Webview crashes when i open app
No message pops up just gives black screen then crashes
Default settings
I was exported my app before and its working but when i export now it doesnt work

When i try to open my app in android 4 it doesnt crash but in android 6 it keeps crashing

This post was flagged by the community and is temporarily hidden.

app also crash when airtable Properties are empty i use block to fill properties by using Obfauscated text to Secure my api or base id and designer Properties are empty than app goes crash so please fill zero “0”
ya some value in designer Properties of Airtable database after that you use block to fill api key, base id or table name with block Obfauscated text to secure your key.

issues with components still persist… at least from my side for WebViewer component.
I can’t unfortunately use any custom component as I use custom made dendritas table by @Andres_Cotes which requires default webview component.
Even if I use a new screen and transfer blocks and components there the issue persists in companion and apk mode.
even if I have all properties filled in and use any other posted in the community…
even if I make a simple app to display the html from internal storage generated from dendritas table extension without even using the extension directly the webview component still get net:err access denied…
latest version of companion is used btw…
is there any chance we get any Kodular update to fix the issues with the components?
or maybe roll back in an earlier Kodular version where stuff used to work as intended???

1 Like

This post was flagged by the community and is temporarily hidden.

Kodular crashes in random szenario, mainly after menu change.

I made several apps, none crashed. This one had some (for me new used) common Kodular components and app crashes. Some times it works for 1 minute, some times it crashes after seconds. I could not detect any information by using USB connection. I reduced the whole project several times and removed components.
If I remove Firebase + Side menu and graph extension and other stuff, it still crashes.

YouTube Video: https://youtu.be/uDaptyRX9eI

Aia Project file

I read this chat as best as possible and tried to not repeat a known issue.

Any help would be great

Three problems in your app

  1. Disable clock always fire in Screen1 from Designer’s properties
  2. About Screen Title is empty in Home nad causes crash
  3. Your firebase’s location is other than us-central1. Since you can not change location once a project is created in firebase, create an new one, set location to us-central1 and it will work
  1. no, in Clock1.Timer > its set to Enabled = false (except if you click explicit the image, then you are right)
  2. I tried before, yes in this version its empty, I updated again
  3. I changed, thank you very much

Thank you for the hint. But…
Still crashes.

I updated the same link

Timer always fire, tested as apk, could not replicate crash, see video
Sila_crash_2.aia (808.6 KB)

1 Like