Displaying Image from "external_storage" not working in compiled apk

No wonder


As I said, copy foto.jpg from the assets to that path …

Is it really that difficult to do this manually:

Since it is no longer possible to do this via the app on Android 11
(without using the → Storage Access Framework / SAF).

Did you not watch my video? I did it manually via es file explorer, I don’t see why you think that wouldn’t work?? The second time I open the app it says true, but still doesn’t show…

Just so you can see, your picture, copied from the assets, into the

/storage/emulated/0/Telegram/Telegram Images/foto.jpg .

location, but still not showing, notice how the “exists” flag is true…

in your test program you are calling the procedures cleanUp and display from the Screen.Initialize event…
this will not work, because you still do not have the required permission at this time…
you should call these procedures in a button.click event and click that button after having granted permissions…
you can remove WRITE_EXTERNAL_STORAGE, this does not exist anymore…


I tried this, it didn’t make any difference…

Try this: imageTest2.apk (5.9 MB)

(It seems that some special devices need this path (for whatever reason):
file:///sdcard/Telegram/Telegram Images/foto.jpg

Sadly still no luck :frowning:

I have also tried most these apk’s on a Samsung Galaxy S21 Ultra as well as my Oneplus 8, but both do the same.

The next attempt (this time with an absolute path, and not a full path):
imageTest3.apk (5.9 MB)


The absolute path works on all of my Android 11 devices as well.
/sdcard/Telegram/Telegram Images/foto.jpg

Full path:
file:///sdcard/Telegram/Telegram Images/foto.jpg

Annoyingly…still no luck :frowning: I tried this on both the Oneplus 8 and the S21

That’s really strange … but we’re not giving up yet:wink:
Next attempt with an extension:
imageTest4.apk (6.1 MB)

Btw, I checked my APKs on many test devices (Android 7, 8, 9, 10, 11). Also on Samsung and OnePlus devices. All APKs (1-4) work on all devices.
I have no idea what’s going on on your devices.

Try also the AI2 version:
imageTestAI2.apk (4.2 MB)

:frowning: neither of these work either…I guess I am going to have to think of a different way to do it…

all of mine “work” in the compainion app, thats the strange thing as well…

Make a screenshot from your device, like this:


I can’t believe this file is there in the required format.

Ok, I think I can guess what it could be. I created this folder manually:
/storage/emulated/0/Telegram/Telegram Images/.

This directory /storage/emulated/0/Telegram/ may be blocked and only accessible for the Telegram app (at least on devices with Android > 9, API > 28). On my Android 11 test device there is no Telegram app.

However, the directory can be accessed via Companion, since the corresponding storage permission is declared there in the Manifest.

Even manual creation is not working.

Manual creation, what?

He tried this.

Where did he write / claim this?
No, I think this directory was created by the Telegram app.

Try this APK: imageTestASD_shared2.apk (5.9 MB)