Does FireBase not accept a Caption as (tag)?

When I use this logical format, I succeed and FireBase returns me an expected logical value.

blocks (6)

But when I use this format, which should, theoretically be the same thing, I don’t get an expected logical return, that is, I can’t add a list to the provided tag. (Sometimes it works perfectly, but most of the time it doesn’t work and it returns me an ERROR).
blocks (5)

My tag is not fixed. It varies depending on the user’s manipulation. As previously said: (Sometimes it works, but most of the time the above error returns to me). I tried to change the Caption to HTML Format, but still this ERROR persists.

Question: What should I do to make the FireBase receive a Caption as a tag? Why does this ERROR happen most of the time?

Curiosity: This configuration works perfectly, but I have problems saving values.
blocks (7)

You can check this guide :point_down:

1 Like

I had seen this tutorial, but it serves a specific tag. I have several tags. Do you have any idea how I can use the for to go through all the tags I have?

I thought the resolution would come from manipulating the Legend itself.

What do you mean with the several tags Do you mean a list of values .

It is a tag tree with several branches.

I went through it one by one, erasing what was inside and updating it as an empty list, I thought it would solve the problem, but I couldn’t solve it.

What makes me confused is that sometimes it works perfectly, but most of the time it returns an ERROR.

It is not constant. Time works, time does not work.

As the guide says :
You should get the tag you want to store your value at , if it was empty Then store an empty list.Now you can use the append value block with this tag, you could do this with any of your tags :slightly_smiling_face: Your tag should be a string, lists doesn’t work afaik.
P.S : you can navigate between different buckets using the project bucket property.

1 Like

So before (Add) I would do this manipulation in the Bucket and in the specific Tag?

That way I would discard Manipulation in the (Initialization) process.

To append a value in a list available in a tag, you should create the tag first. So, when you use this format, you are actually adding a value to the tag which already has a value.

Whereas, when you are using this method, you are adding a value to a tag which does not exist at all. Remember, we can only append a value to a list if that particular list already has items. We can not append value to a null list but we can add value to a null list.

There’s a difference between append and add. While using add function, we are adding an item to the list while append function can only be used with non null list.

So no matter how you will try, you will always get an error if you use your second point. Hope you have understand the difference. :slight_smile:


Thanks for answering!

So … The tags exist and some are empty and some are not. When I use the second configuration, that is, with a variable tag, using a Caption; things may or may not work.

I did a test right now and it worked perfectly. So the logic is correct, but Firebase does not accept this configuration all the time. It just doesn’t work sometimes.

I wanted to understand just that: why doesn’t he accept this logic in all cases? It’s very weird.

I will fill the tags with some value. Can this help me? Thanks.

The Caption represents an existing tag.

Yeah. Make sure that the value inside your tag is not empty then it’ll work everytime.

I think the reason behind its working sometimes and sometimes not, is because the value inside the tag initialises and becomes null.

1 Like

I’m inserting values inside the tags.

If you get a positive answer in all tests, I will come back to notify you as a solution. :heart_eyes:

Thanks for answering. :smiley:

1 Like

I think you should share the solution with @Chirubot :heart_eyes:
He also contributes to this.

The solution was to make sure that the tags were not empty. I filled them out and removed the list store.

I hope that ERRORS don’t return to me now.

Thank you for helping me! :kissing_heart:

1 Like

Began to return Error kkkkkkk
I give up. I will have to migrate to another system.

Show your blocks. What you’ve tried again because I am not getting any error. :thinking:

1 Like

Are you trying to save multiple values?

If you are saving multiple values then you can do like first get all saved values in 1 variable and then save value with…

join variable +
any character which is not in your data like #*# +
your new value

And when you try to get the value then split the value at your given character in my example it was #*# and save the value in a list…

1 Like

@heliocesar84 This should work,
Just test the AIA,
I modified some of the blocks
JobsModificado.aia (379.9 KB)

1 Like

Fantastic! I don’t think it will return ERROR now.
Amazing! You compared my Legend to the System tag … Incredible. Nice reasoning! Thank you. I don’t know how to thank you.

1 Like