"Error 1103: Unable to post..." when inserting data in database

Hello, I always got this error while inserting data in mysql. I already exported the app and installed it in my phone since I can’t use Kodular Companion because it turning off quickly. I don’t know if the cause of the problem is from my source code or somewhere. I already searched this error here but still didn’t found something to help me solve the problem.

This is the source code:

$host = "localhost";//serverhost
$username = "username";
$password = "password";
$dbname = "dbname";// database name


$Tk_SchDate = $_POST['Tk_SchDate'];
$Tk_Time = $_POST['Tk_Time'];
$Tk_PassName = $_POST['Tk_PassName'];
$Tk_Branch = $_POST['Tk_Branch'];
$Tk_Route = $_POST['Tk_Route'];
$Tk_Seat = $_POST['Tk_Seat'];
$Tk_DateAdd = date['Y-m-d'];
$Tk_Price = $_POST['Tk_Price'];
$Tk_Stat = "ACTIVE";
$Tk_CusID = $_POST['Tk_CusID'];
$Tk_CusName = $_POST['Tk_CusName'];

$conn = new mysqli($host,$username,$password,$dbname);
$sel = mysqli_query($conn, "SELECT * FROM qrcode WHERE Cus_ID='$Tk_CusID'");
$result = mysqli_num_rows($sel);
    $rows = $result->fetch_assoc();
    $qr = $rows['QR_ID'];

    $ins = mysqli_query($conn, "INSERT INTO ticket(Tick_Sch_Date, Tick_Sch_Time, Tick_Pass_Name, Tick_Branch, Tick_Route, Tick_Seat, Tick_DateAdd, Tick_Price, Tick_Stat,QR_ID, Cus_ID, Tick_Cus_Name) VALUES ('$Tk_SchDate','$Tk_Time','$Tk_PassName','$Tk_Branch','$Tk_Route','$Tk_Seat','$Tk_DateAdd','$Tk_Price','$Tk_Stat','$qr',$Tk_CusID','$Tk_CusName')");
          echo "You reservation has now been sent";

This is my algorithm:

I removed your password etc to be on the safe side.


oh thanks I forgot to hide it :fearful:

1 Like

Why dont you refer this guide before analyzing your problem? Pls go through it and slightly adjust , it will work


still the same :cold_sweat:

Are you using anytype of free servers ?

Did you try with post text block?

@Balajidev yea and @Still-learning yes and the error is still the same

Try this

Try : Use the Screen.ErrorOccurred event and check the 'Parameter Error Number.

1 Like

I am using phpmyadmin. Do you think it will work? It’s been 4 days and I still have this problem. :cold_sweat:

I already used that and it doesn’t solve the problem but it only handles the problem. :cold_sweat:

Contact me This Can Be Helpful

Use the Post method rather than Put…


Already i suggested @Taifun but he says still it persists…

I think the problem could be due to multiple join block ? Only one join is enough but has used multiple join if so how app will read this.?

1 Like

Post a screenshot of your updated blocks

1 Like

I think there is a mistake in one of the letters of your sentences or you forgot a certain letter. I faced this problem many times