Error 400 - Bad Request

https://edumais.com.br/kodular/mysql-financas.php.zip

Check that the php code is connecting correctly to your database. Check username and password. In some databases the servername is “localhost” and in others you have to put a url.
Which server do you use?

Show your code to see if it has any error. If you put a wrong comma or write a wrong space it doesn’t work …

1 Like

If I use deep host extension, this php script works ok, so no error with connection on my php

Do you right “my secret pass” as sql key

There is a connection error…

Here’s the code that connects to your database. I get “Bad Request”. I think it means it’s not connecting to your database.

man, my secret pass is [email protected]@md:g

my secert pass is [email protected]@md:g

after I will change

I’m talking about your sqlkey. Is it: my secret pass

NO, it is:
[email protected]@md:g

Then why are you writing in the php:

Just a sample man above,
I am using like that:

/************************************CONFIG****************************************/
//DATABSE DETAILS//
$DB_ADDRESS="localhost";
$DB_USER="u109863032_financas";
$DB_PASS="[email protected]@md:g";
$DB_NAME="u109863032_financas";

//SETTINGS//
//This code is something you set in the APP so random people cant use it.
$SQLKEY="[email protected]@md:g";

/************************************CONFIG****************************************/
1 Like

Solved!
I Just changed SQLKEY to string without special caracter and now works

3 Likes

I think this is import to say on tutorial

1 Like

:partying_face: :partying_face: :partying_face:

1 Like

Agree…May be @Taifun can check that…

1 Like

Thanks @Mohamed_Tamer and @pepocero for suport.

1 Like

You’re welcome :sweat_smile: :grin: happy you got your solution.

1 Like

note added in the documentation
thank you

Taifun

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.