Error in App Bundle for Deploy

Filks, I tried to genarate the bundle to deploy the app but I received this error:

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT2 compile time: 0.442 seconds
AAPT2 link time: 0.542 seconds
________Compiling source files
(compiling io/kodular/mkt_clestonleal/WADirect/Screen1.yail to io.kodular.mkt_clestonleal.WADirect.Screen1)
(compiling /tmp/runtime1516273123127933139.scm to
Kawa compile time: 4.298 seconds
________Invoking DX
DX time: 3.641 seconds
___________Creating structure
___________Extracting protobuf resources
________Running bundletool
________Signing bundle

I would like a help to fix this. What I did wrong?

Now if you want to compile your project you have to pay the premium subscription. I have the same error after 5 months developing my App

Does it build as apk if so then just try again

You can still build under free plan

:rofl: typo

I think I am in trouble because I got a premium subscription in the account that I have tried to render it.

I assume you mean, “still”. If so, then you can only build if you don’t have ad components in the app.


Yes, but I think that in my case I use more than 5 extensions in that project, then I will see the possibility of subscribing to the new plan, thanks Boban!

Ok! I will try to wait a bit more time to see if this problem can be resolved when the ad permission was granted. If this situation continue I’m going to be here again asking for help.

Thanks bros!