Error: invalid_request (Mismatching redirect URI)

I checked out Bugs in Kodular Eagle before creating a new topic

Describe your issue

A month ago, this has happened to me for the first time, it happens like once every three tries, and then (most of the time) disappears.
Now, I can’t login to the creator since 3 days. I’ve tried like 20 times, changed my browser, device, VPN, cleared cookies - nothing helped.
Sometimes, I am able to log in if I go to, and then I log in, and go back to the creator. But now, the error also happens there.

Steps to reproduce the issue

Go on

Expected Behaviour

Asked to be logged in

Actual Behaviour


Tried in Brave, Firefox & Chrome

Redirect URI

The full URL

A staff member, PM me, and I’ll give it to you.

What about MS Edge?

I uninstalled it some time ago

Let me check whether I am facing issue or not.
But most of the Kodular sites are not working at this time.

The issue started like a month or two ago

I am able to login to creator on Edge.

i know, sometimes it works, somrtimes it doesnt

ive tried like 15 times in the past few days

it for me to, so i got directly not

Both are same actually.

no they are not same. 1st one has only c at first and 2nd one have creator at first

is a shortened url for

1 Like

Make sure you are accessing to

I surely am

Dont you have force-SSL?

This happens to me too sometimes. If this happens and I continue to hit the refresh button, then no matter how many times I refresh the page, same error persist.

So what I do is, I clear out the URL bar totally(make it blank) and then again type the address directly as and surprisingly it works everytime :smiley: I don’t know how. :man_shrugging:

1 Like

Sometimes changing http to https in the redirect uri works