FileTools : Some tools to work with files

Yes, that block is there.


The block I am looking for is


1 to 2 mb file is not being copied … from Assets

Yes, use

  • the TaifunFile extension from @Taifun or the
  • File compontent which, however, still mistakenly requests storage permission (this is a bug).


But @Taifun this extension not working in android 11…?

You need to use SAF for android 11


It no longer exists.

Of course, it works (also on Android 11).

This works on all Android versions (Companion & APK):

@vknow360 yes… In a app

Show the blocks.
Also make sure you are using latest version and let me know if aix in the first post is not the latest version.

Look it… :point_down::point_down::point_down:


Are you sure assets’ path starts from /? Because I am not sure about this.

They must start from //.

1 Like


Yes… You are giving example… :point_down:

I have tried… Small File size like KB is worked properly, but Big File size approx 1 to 2 mb not working…

So it needs some time to copy files.

Error Massege are coming… :point_down::point_down:

Can’t Copy a directory!

Post a simple test aia that reproduces this problem.

I have already said that to access an asset file, path must start from // followed by file name.

As I said before, copying from assets no longer works with your extension for the compiled app (APK). TaifunFile works …

FileTools_test2.apk (5.8 MB)

1 Like

ChangeLog Version 10.1

  • Fixed bug in IsFile method which was not working for Asset files.
    It was affecting copy and move operations.
    Reported by @Mr_PRAKASH_THUL and @bodymindpower


Problems have not been fixed yet … I tried