Question about Taifun File extension

Good morning all.
I want to switch from AppInventor to Kodular.
However, I have a problem with the TaifunFile extension.
I made a very simple application to copy a file.
It works great with AppInventor but not with Kodular.
You have an idea ?
Thank you in advance.

copie_simple.aia (729.2 KB)

Are you getting any error?

1 Like

Try with /


1 Like

No TaiFun File extension is working properly and I also used in my latest app and extension also working perfect in android 11 there is no issue in extension. You need to ask permission a “WRITE_EXTERNAL_STORAGE” and then it will work perfect. I guess :thinking: you forgot to ask a permission

Saving to ASD should not need this…


@Boban is correct, the TaifunFile ext. doesn’t require READ/WRITE permissions for the ASD, but the File component does it wrongly.

it’s ok without / in appinventor. I tried with it in kodular, it doesn’t work

Yes : "[quote=“Kenin, post:2, topic:106857, full:true”]
Are you getting any error?

Yes, i have “Sorry, file to copy does not exist”

Sure it does, in your case the file name will be and not

1 Like

No !!! it doesnt work. You can try : copie_simple.aia (729.3 KB)

are you using the latest version of the file extension, which is Version 13 as of Oct23th, 2020?
EDIT: your issue seems to be the Kodular logic of storing assets in directory /Makeroid… and this has been corrected in the latest version…


Yes. I use it image

It seems that they have changed this again, to /Kodular

Edit: this is on Android 9 however, the above code works on Android 10

there was an issue in the extension…
I now fixed it… see attached example…
you now can find Version 13a of the file component here App Inventor Extensions: File | Pura Vida Apps

copie_simple_taifun.aia (522.8 KB)


Nopp, Android 9

1 Like

thank you @Boban… it seems to be more complicated depending on the Android version?
did Kodular change the assets directory for the companion app depending on the Android version?
I was testing on Android 10 and there /storage/emulated/0/Makeroid/assets is the correct path to the assets for the companion app…


With the same aia:
AppInventor :

At least on my devices

Android 10, assets path is /storage/emulated/0/Android/data/io.makeroid.companion/files/assets/

Android 9, assets path /storage/emulated/0/Kodular/assets/

Honestly it’s a big mess with Kodulars paths


Try this path


It’s working now. Thank you Taifun for your responsiveness !!!