[Free] View Tools - Visible Component Tools

View Tools
This extension has many useful methods to get information about visible components.
Specify visible components in methods to get information.


Blocks:

Get Methods (127)


Documentation

View-Methods-Documentation

Scroll down to Get Methods


Note: Some methods are not present in the extension

These (18) methods are not supported in AppInventor / Kodular

getAccessibilityDelegate
getAnimationMatrix
getAttributeSourceResourceMap
getBackgroundTintBlendMode
getContentCaptureSession
getExplicitStyle
getForegroundTintBlendMode
getHorizontalScrollbarThumbDrawable
getHorizontalScrollbarTrackDrawable
getImportantForContentCapture
getSourceLayoutResId
getStateDescription
getSystemGestureExclusionRects
getTransitionAlpha
getUniqueDrawingId
getVerticalScrollbarThumbDrawable
getVerticalScrollbarTrackDrawable
getWindowInsetsController

I will try to implement these (12) methods in upcoming updates

getAttributeResolutionStack
getDefaultSize
getDrawingRect
getFocusables
getFocusedRect
getGlobalVisibleRect
getHitRect
getLocalVisibleRect
getLocationInSurface
getLocationInWindow
getLocationOnScreen
getWindowVisibleDisplayFrame

Next Update: Set Methods, So you can set properties to visible components.

Download

com.sonu.ViewToolsGet.aix (17.2 KB)

10 Likes

Good extension :+1:

1 Like

Nice Extension, so many blocks. I understand use of some of them only :sweat_smile:

3 Likes

BTW, you should follow the naming convention:


get should be Get in all of the 127 method :sweat_smile:

1 Like

Yes, I used lowerCamelCase because the android documentation uses it.
So the user will not get confused while referring to the documentation.
It also looks good, so lower case words show get , set the type of block.
I will change them in the next update if it’s a mandatory rule. :slightly_smiling_face:

1 Like

Interesting Extension :heart_eyes:

1 Like

Thanks :grinning:

Yes it is, if you are going to publish this extension, also see here:

3 Likes

Nice Extension. :thumbsup:

Surely -

:+1:t2:

another possibility would be to just remove the “get”… these are Getter methods anyway… so for example you easily could replae getDrawingCache just by DrawingCache… simple is best… thank you…
Taifun

2 Likes

Thank you :smiley:
@Mohamed_Tamer
@Maayur
@asifakhtar91298_pers
@ADDYLIN
@Taifun

2 Likes