FTP Kodular - Application closes without any message

This post was flagged by the community and is temporarily hidden.

1 Like

Upload file after connecting FTP. Change upload blocks to " When ftp connected" blocks…

Unfortunately it didn’t work! Continues to close the application when the “conect” is executed.

I did the following test. I left only the “conect” without the other blocks and the application was closed. So the problem is in the “conect”, but I have no idea what happens.

Show Ftp properties?

Use onerror block

The application is closed before the upload error block is executed.

Why are you creating multiple post when there is solution if not use that thread don’t create new topics

I’m sorry, but I didn’t find a solution to the problem, so I’m insisting on asking for help.

This post you posted is about another error that was also not solved with Kodular FTP.

We’ll check into it.

Friends, I haven’t come up with a solution, but I can comment on some conclusions. 1-My app had 9 screens, I reduced it to 5, the aia doesn’t have more than 8MB.
2-I created a screen just for FTP,
3-My app works with the extensions: DotsView, VerIp, DataTools, Taifuntools and Phase.

When I ran the page created from FTP, the app ended, just like in previous versions with more screens.

So I took the same sequence of blocks and created a new project with only one page for FTP. It worked!

I can deduce that Kodular FTP is creating conflict with some of the extensions I am using.

Now, I’m going to create several versions of the app each without an extension and see which one FTP works on.

After the tests, removing one by one of the extensions, I found that the extension that was conflicting with the Kodular FTP component is DateTools.

How does DateTools conflict with FTP ??

I think it is not the extension itself, but blocks of this extension related with ftp, which were used wrong.

I can’t explain it technically, but as I explained above, I was removing one by one of the extensions and only when I removed DataTools did FTP work, that is, the application was not closed when I called FTP.

I did the following experiment to not make a mistake in the statement. I repeated the blocks in a project without DataTools and it worked. Therefore, the FTP blocks were all correct.

Statement from the developer

1 Like

Hi @Hossein (if you don’t mind)
Does FTP component use Apache Commons Net lib? :thinking:

Can you show how you are using DateTools? @ledumelo