Go url web view, net::ERR_ACCESS_DENIED

Hello, since the last update 1.5.2. I can’t get a .html file which is created with the file component and I save it in the folder: / android / data / (app name) / files / but when I indicate this path it comes out. net :: ERR_ACCESS_DENIED. I have the authorized permissions and with the application compiled both in android 9 and 11 it

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select “Download Blocks as Image”. You might want to use an image editor to crop etc. if required. Then post it here in the community.


Hello, I have the same problem, it seems to me that you need to give some permission to access the file in the path “file:///storage/emulated/0/…” but I don’t know how to do this, until Fenix 1.5.1 worked after the update to Feniz 1.5.2 stopped.
Has anyone who has been through this problem got a solution?

I still have no solution for this error I have even tried with the “customwebview” extension and nothing.

Since now you have mentioned the extension so I would like to see the blocks.
Something with its configuration is definitely wrong.

Here are my blocks with both the integrated webview and the customwebview, the latter closes the application.

Outcome with webview

This is how it works but in companion with the compiled application , what would be the path? and if it works with api> 29

Please show complete blocks of Customwebview.
I am unable to locate SetWebView and FileAccess blocks there.

I have no more blocks. That is why that extension does not work for me. Because I don’t know how to use it.

I’ll post the blocks as soon as possible.
Till then make sure to have a look here:

It doesn’t work either

Try removing 1 slash (/) before android in file path

The File is created and pointed fine to it, but it appears that it is not accessible to the file.

what is the value of nombreDeArchivo?

try to create a small example project as small as possible and add it into your thread, so someone can check

EDIT: btw where is your example project (aia file)?

Same issue i am facing, i have copied images from gallery to ASD.
I am using customwebview to display the image.
In the test example i have manually pasted the image in Android/media folder and trying to display in webview
aia is also attached

try23.aia (67.8 KB)
getting Error

Because you haven’t enabled FileAccess property before loading file.
Make sure to ask for Read External Storage permission before enabling the property.


same error



Thanks it is working

1 Like

I put my .aia for your examination, with customweview I managed to make it work but with webview I can’t, I need it to work with webview because my application is made with it and I would have to change many blocks. If there is no solution or I have to wait or work on the changes. THANK YOU
prueba_archivo_visor.aia (101.9 KB)