[Guide] App not open / open button disabled after install

Have you renamed it back to .aia

1 Like

Yes yes… sorry so much. I just had another folder in which the files were but not directly in the zip file. Sorry Sorry hop you’re not

:roll_eyes:

this time :grimacing:

Thanks a lot.
It worked properly.

1 Like

Thank you so much ! :slight_smile:

it didnt work :cry: , pls help

Thank you so much ! :grinning:

Amazing!
Jajaja it really works, the only bad thing is that on each screen you have to run the same process because if you only run one screen and go to the next one it closes xD

Thanks!

Hi everyone!

I’m getting mad with a project what doesn’t open in my phone
I’ve tried all of what i watched in topics and guides
Fortunately, this topic is open for answers

My project gets easily built as an .apk file and i can rightly download and install it to my phone
Then, when i try to open it, it shows a white screen during half a second and fastly close down
It’s taking around 10 days for me to find a right solution
I’ve watched a lot of topics and answers in this community forum, and i’ve tried a lot of things

I’ve done all kind of things like:
I’ve renamed .aia as .zip
I’ve changed data in ‘screen1.scm’
I’ve checked and changed data in ‘youngandroidproject’
I’ve renamed back to .aia and upload to kodular
I’ve used another account in Kodular, working in another browser (firefox and chrome), importing the project and then downloading it… several times
I’ve changed either enable or disable screen splash, show lists as jason and some others properties…
I’ve deleted keystore
I’ve deleted ‘activitystarter’ in my screens
I’ve changed and deleted API keys and app name and package name…
I’ve copied several times my project to another name for tryings
I’ve deleted some screens in my project, even until only Screen1 (with very few blocks) left…

After all of those things, I also tried to clean cache, restart my phone, and so…
And one and other and other time, i downloaded and installed my project into my phone and so…
And i always got the same negative result: white screen for a half second and closing down
Any other project i built in kodular before is rightly working for me
I really feel that all of my work is getting away…

I really would warmly thank any kind of tip.

Have you read Avoid Crashes of the Application for some of the components

Otherwise use logcat to find what causes the crash

1 Like

Thanks Dora for your fast answer!
I hope i will understand your two tips, and tell here about it

Thanks (again)!

1 Like

Well, I followed the tips in ‘Avoid Crashes…’ topic
I filled up some of fields what is talked in the topic and it worked well!!

So, thanks for the tip and thanks for the topic, since it is quite hard for a begginer like me to suppose that that is the topic to be watched

1 Like

Hey, that’s why Avoid crashes topic was still globally pinned in community.

Hey, thanks for clue
But I don’t know how is that pinned topic supposed would have to appear in front of my eyes, looking for what or where? No idea
As i was searching for “app doesn’t open in my phone after installing” and some several similar ones, it never appeared that pinned topic…
Thanks if you make me learning one thing more

This is what happens in nearly every forum in existence. Important topics are always pinned at the top.

1 Like

At last, I’ve found it!!
It appears in the main page of the K Community forum by clicking the icon at the top
I didn’t know that it was there, impossible to imagine for what problems you have to look there, since i typed about my problem in the text box of the glass :mag: and no pinned topic appeared there…
I suppose there has to be some place where it says you need to look for pinned topics before to look into the forum
Then, from now on, i’ll do it so
Anyway, thanks for advice

2 Likes

Fantastics!

The solution still works @2022, thank you :sunglasses: :+1::sparkles:

The .zip does not convert back to the .aia file.

how can I do it