Help needed in finding error?

i tried everything but could not found any such block from which the error comes? please help me to get rid of this error. Even i have set limit but i dont know why it still goes to number 2 ?

Full block

And the error is???
You must mention the error before publishing the topic without knowing your error then how could your issue will be solved?

1 Like

Your list contains only one item and you are trying to get second one. Unfortunately the error hides the blocks. Try in every select list item list block to use Do it and debug your blocks

It’s look like You have 1 error block and 1 warning block
image

better you solve that firs by clicking the up arrow of error or warning … you can found the error of the block

How do you get this length, show us or you test yourself also why here is red cross? Is it appears while you debug? if so please correct the length of the list

That is because i used Do It option? That is what i want to solve

Why it is going for number 2 if length of list is only one​:face_with_monocle:

Error is the length of list is 1 and i have set that is number loop but why it is going for number 2…not only this when i have length of list 4 it goes to number 5 also…why?

I get list from airtable

In your process you use many times the select list block, the error might come from any of this blocks so check them one by one

Sometimes in list items there is empty list at first so i suggest you to check that and also let me suggest you temporary solution, Just use while you select list item use index number - 1

But all are same and if there is error in one block then there will be error in another blocks but according to me there is no such error in any of the block except Number loop block

Then i think that will leave one number in loop…gud suggestion but can’t do this

fixed the bug, the error was because of 3rd number loop block(it was automatically converting number1 to number3

?

I don’t think so… this block won’t convert any loop. Instead it will check number by number from to the end by 1. Mistake is there in some other place.

you are not getting me i mean when i copied this block from above the number connected to select item from list was ‘number1’ but when i put that block under another number loop block (namely ‘number2’ and ‘number3’ )then it automatically changed the block ‘select item from list index number1’ to ‘select item from list index number2 and number3’ hope you understand

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.