Image Problem - List View Image and Text

I have been working on this (what i thought was simple) task for two days straight now…
I have searched for hours through the online communities…

see attached AIA and image of my blocks

each image taken should be added to the LIST VIEW IMAGE and TEXT
and it does this correctly only the first time i test or use it on the phone

after i delete ALL the images from the phone AND refreshing the companion or restarting it or restarting the phone or anything the images are not showing correctly in the LIST VIEW

the images shown the second or third or more times afterwards show the ORIGINAL FIRST images from the first run of the app

the only time it works correctly is if i change the save directory of the images
then it will work right the first time

for example i have it saving to /OQ/JPGs/
i take a picture of a cup
it shows up correctly in the listview

i then delete the image of the cup from the phone
i then refresh the companion app
i leave the directory the same (/OQ/PNGs/)
i take a new first picture for the list view of a mouse
the first image in the listview shows the picture of the cup again which i deleted

therein lies my issue

please let me know if i can provide anymore images or information
any help is greatly appreciated

thank you all so much!!

jpgTest.aia (77.1 KB)

What’s the main error tell in one line i will help you

1 Like

When you add an image in listviewimage for first time it save that in cache after that when you load the same image in listviewimage it get it from cache

So i think the problem is in cache

1 Like

I test your apk but its working fine

1 Like

thank you so much for the reply!
how do i clear it from the cache? i have checked the cache and see nothing in there … unless there is another cache somewhere …

im running it on a galaxy note 20

thank you so much for the reply …
i was gone all day yesterday sorry for delay …

its hard to explain it in just one line
thats why i put all the information i could in the original post
i could send some more screen shots if that helps

i just tried it again
first i deleted every JPG on my phone
i searched for the cache folder and deleted everything in it
i went through every folder on my phone and deleted anything that was an image

then i ran the app again
took a picture and its coming up as the same picture i took two days ago which is no where on my phone that i can find

i dont understand what im missing …

ok no problem let me read the original post and then i will put forward my suggestion or solution thanks

1 Like

thank you so much for your time!!
let me know if there is anything else i can provide

i have found a solution i believe
i have incorporated Taifun’s Tools extension and utilized the clear cache block
this seems to have quelled the issue
everything is working the way i intended now

if anyone would like me to post the updated AIA or an image of the blocks please let me know and i would be happy to do that

thank you everyone for your time and input!!

Would you show us, how to clear cache block
Thanks