ImagePicker Bug?

Describe your issue

I have this AIA file that shares a picture either taken with camera or from the photos in device.
When I use the ImagePicker, The AfterPicking event generates an error:
Runtime Error

“call to ‘ImagePicker1$AfterPicking’ has too few arguments (0; must be 1)
Note: You will not see another error reported for 5 seconds.”

Steps to reproduce the issue

Expected Behaviour

Same AIA file works without errors in Appinventor and AppyBuilder.

Actual Behaviour

Show your Blocks

share.aia (2.3 KB)

Android version


Make sure your blocks are correct without warnings.

What happens if you run it as apk?

Thanks for you reply Mika.
I checked the blocks and they have no warnings/error as shown in screenshot.
Any idea? (did you get any warning/error when loading AIA)? I don’t.

What happens as apk on your device?

Hi Mika,
It worked just fine, no error. Maybe something with companion?
Anyway, I really appreciate your quick response and help.
Have a good one!

1 Like

Do you use the latest companion version?

1.1 Butterfly.
Is that the latest?

No. 1.1.2

Ok… I’ll try that and post back.
Thanks again!

Thanks for the private mail.
I will check that as solved.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.