In App Billing (IAB) Issue Proof with small AIA

(Cian) #1

Google now allow for an in app billing test for products without having to upload you app to the playstore.

You still need a merchant ID and License

However the Kodular IAB Component is not working properly. I have created the smallest test version possible of IAB and have attached it here. You will see that it only populates subscription details on original application install.

You can still buy products, and consume them, howeverthese two events are not triggered, even on demand, and nothing shows up in logcat.

Here is the AIA file. Replace the Merchant and License with your own and give it a try.

I would love at least someone to confirm this is not my issue and is happening to others. I followed my own rules, and recreated the problem in as few steps as possible.

IAB_Test.aia (3.4 KB)

3 Likes
What happen with inApp Billing?
In App Billing After Purchase Event Bug
In app Billing , Help
Compras desde la aplicacion, Google Pay
(Yusuf Cihan) #2

I can confirm the After Purchase event issue. I tested in my app, and I can only check with method to see if purchase made. I can’t use event. I thought this issue coming from my side. But looks like there is a issue.

2 Likes
(Pme) #4

Yea ı got same problems with billing component .my user already purchased but is it purchased return false and if when i use load owned purchased its not trigger handler

(Aravind Chowdary) #5

Yes, IAP component has some bugs… And they will be soon fixed by @pavi2410

(Cian) #6

Last he mentioned to me he could not find the bugs.

(:)) #7

Is there any updates on this? my project is still stuck waiting for a fix on this.

(Cian) #8

David,

If it is urgent you need to use Taifuns extension. However @pavi2410 mentioned that the bug might be fixed in the new release and to test it then.

He messaged me today about it.

Peace Out.

1 Like
(:)) #9

@cian thanks for the update, now im gonna do my work :joy: P.S removed the tag.

1 Like
(Pme) #10

Alternative : Enhance extension support IAB

Edit:

I think its still not working,new update didnt fix it

Version 1.3B.4

(Pme) #11

I think new update didnt fixed IAB.Can you check @cian? ıs it same like old version or ı just do somethink wrong?

(Cian) #12

I have not tried it yet.

Are you able to load purchases, or what is the issue?

(Pme) #13

I tried load owned purchases and check is my product ıd is in list And i tried use is purchased block.

Its works only for first time but its not work later.

(Cian) #14

Did you try with the simple AIA that I created, and replaced the component?

(Pme) #15

I tried on my own app