Issue with file component?

After choosing a txt file i have the error:
Error 2101: the file test.txt could not be found.
I tried also manulay paths and the error is the same.

I think the problem is on file component after a lot of tests.

  • I have Read/Write permission and i chose a txt file.

Hi @papavasileiou87
Do it Application Specific Directory block and post result here.
It will not work until you provide correct path.
Use same path (output path used in Copy method) in Read From method.

The file going to private folder after that could not read it.

I have exactly the same issue

No this is not true.You can read/write from ASD folder also.
Try this path:
Application Specific Directory + /test.txt

If you mean that is not working…same error

Hi @papavasileiou87
Can you Do it Application Specific Directory and show me the result?

Are you facing issue in companion or apk or both?

on both my friend. Also i tried manulay paths. The isseu is on read of file component if understood correcttly. Have anyone the same problem or only me?

Thanks for your reply

1 Like

Please make a good title.

1 Like

Sorry I will fix that

So why not follow the solution in that post

There is not solution. I tried to replace this segment of path but same error.

It wont work in companion, only as apk

Ok I will try all possible solution and on apk and I will tell you. Thanks.
There is another block on extension f.e. to read text from a file?

Read from file, use replace segment with your blocks



Yes works!!!
Thanks a lot. Because on some devices with diferent paths like /mnt/sdcard/ i have a solution with that.