Issue with the Component to Image Extension

Hi All,

I am trying to save an arrangement to text using the ComponentToImage extension. Could you please verify my below block, it is not working. It asked for my permission, first time I clicked on the save button, but the image isn’t getting saved.

Appreciate your help. Thanks!

move the second convertToImage method into the Screen.PermisisonGranted event

1 Like

I am sorry. I’m bit confused. You mean in if block?

1 Like

Remove /storage/emulated/0/… just directly give the name it will automatically save that into internal memory…

And remove component to image block from false part of your condition…

I tried that and it is still not working.

that’s working for me…
even i’m using it in my project

I have just added the extension and these blocks. Is there anything else that I might be missing?

would you like to share aia??

Try this:


Thank you so much. I got notification that it worked. I am not sure where it is saved because I don’t see in Gallery/File Manager. How can I save it so it shows in Gallery. Could you help me with that as well.

This may sound little bit strange. I found the location where the file is saved. When I open the file, it is completely blank but when i click on edit and add filter, I could see the original image. :sweat_smile:

I tried change the file format from png to jpg but still it is of no use.

Anon share your AIA please so that community can troubleshoot the problem :headphones:

1 Like

I have shared my aia file. Please let me know what changes I need to make. Thanks!

quotes_copy.aia (319.2 KB)

I just replaced


and there were no error…
Here is the image i got

Here’s the aia :- quotes_copy_fixed.aia (319.4 KB)

Hope it works for you :heart:

Thanks for your help.

The white screen is still there. I guess in your attached image also white screen is displayed and when I click on it, the black screen and text appears.

but what about when you compiled your project this time

Same…White Screen is still there

May be
you cant see the text because the background image of your component in app is none/white

Try changing your vertical arrangement background color to black or something else then it will be fine…

you can also try changing the text color to something else :heart:


Ah Thank you so much! It worked

1 Like