Kodular hangs at "20 Establishing Secure Connection"

Having the same issue.
Companion hangs at 20%
Tried clearing all data on chrome, reinstalled companion still companion hangs at 20%
Tried using Firefox get error An internal error has occurred. Report a bug?

Desperately waiting for guidance

3 Likes

Try by creating new project, if it connects properly then your main project is probably broken…

1 Like

I usually clear data of the companion, then delete the “Makeroid” folder in /storage/emulated/0.
If nothing works, I would try to open a test project because the original project might be corrupted (happened to me once)

1 Like

Thanks for the feedback
I have deleted the Makeroid folder
How do I clear data of companion?
I have uninstalled companion and installed again, still hangs.
I have deleted the project and uploaded a working backup, still hangs.
How do I clear data of companion? This is what I have not done. Can you please show me how?

Which device do you use? This varies from device to device

Did you try this

otherwise you may have encountered this

1 Like

kodular companion stuck at 20 %

3 Likes

Which browser are you using? I suggest using Firefox, Chrome doesn’t work well with Kodular.

2 Likes

Just uninstall it and reinstall it

1 Like

Chrome browser

Yaa Mine Too

From Yesterday It Get Stop on 20% I Also Tried to Clear data & Cache Data but nothing Happen.

I am Trying Now But Still it stop 20% I also Trying in PC but It doesn’t work here too

4 Likes

I was tried but still same problem

3 Likes

Possible reasons.

  1. Both of them may not be in same IP
  2. Poor network
  3. Browser problem

Possible solutions

  1. Clear data and cache of companion app
  2. Check network speed
  3. If you r using latest OS, shift browser to Microsoft edge
2 Likes

Not necessary, My phone connects to a different WiFi than my laptop but everything works fine, the only thing we need is for the phone to connect to a WiFi.

1 Like

same problem with me from today

1 Like

Use In Firefox

My Working In Firfox :grin: :grin:

4 Likes

I also encountered this problem, Can’t Google’s products use Google Chrome?
It can be used when switching to Microsoft Edge.

1 Like

@Jheferson_Fonseca I also faced same.

I have a suggestion for you and it worked for me: Try connecting your both devices on the same network

Yesterday everything was right but today its stuck

To Resolve It

1. Create a empty project in kodular
2. Connect The empty project with companion
3. Open that project which you are working on
4. It will Connect

Due to

1. Too Much of blocks
2. Too much of assets
3. To much of extensions

1 Like