Kodular hangs at "20 Establishing Secure Connection"

You are using the latest Chrome i guess. Use Firefox. Please next time search the community. This has been asked before.

1 Like

I use Microsoft Edge all the time. I will install and try Firefox. I searched for the subject, but it was asked a long time ago and there was no answer. Thanks Peter.

The problem was fixed when I turned the browser to firefox. Thank you very much, Peter.


I use Brave myself, no problem there also.


Now I installed it too. Thanks :slight_smile:

Very interesting. I tried 4 browsers.(Edge,Chrome,Brave and Firefox) only works on Firefox now…

I have this version
Version 1.20.110 Chromium: 88.0.4324.192 (Official Build) (64-bit)
Still working for me.

1 Like

I tried that version now. It didn’t work again. Anyway, continue with Firefox. Thank you again.

After upgrading to Brave Version 1.21.74 Chromium: 89.0.4389.72 (Official Build) (64-bit)

It no longer works. FF here i come.


Reinstalled my old version of Brave and it is working again. :grin:


I’m Try To Test my app using Kodular companion but live test stuck on 20% process I wait approx 1hours and still stuck 20% and my net speed is 200mbps

Welcome. A lot of users don’t search before asking a question. Yours was merged here. See the above reasons and fixes. Please next time search before asking.


I’m also having a problem since yesterday. I already reinstalled, I cleared the cache and it continues without advancement. I’m generating the APK at every step to check if it’s working

If you have the same problem as stated above you will find a workaround if you read the topic.


Without VPN Kodular hangs at 20 but after VPN connect in mobile phone then open Kodular Companion it’s working fine.

1 Like

Works for me in Opera GX

1 Like

What is the definition of (Many Blocks)? Does Kodular define a maximum number of Blocks per screen? I did this research in the Community, but I found no answers. :grin:

Connection to Companion app still stuck at 20% from yesterday (for me). :worried:

And it will continue until you read the whole thread and find a solution in it …


The Solution is to use any Non-Chromuim browser. I prefer using Firefox and if you think that you’re data is any other browser (Login Pass etc) you can copy it in Firefox check the installation for Firefox…

Firefox is working pretty well. The issue is caused by new updates in Chrome Browsers which is affecting every Ai2 Builder.

Though said many times in threads people keep asking the same thing… Please read the answers given multiple times…

About Chromium Based Browsers.

Chromium is a free and open-source software project developed by the Google-sponsored Chromium project. The source code can be compiled into a web browser.

Google uses the code to make its Chrome browser, which has more features
than Chromium. Many other browsers are also based on Chromium code, most notably Microsoft Edge and Opera.

Few Notable Chromium Based Browsers–

  • Vivaldi
  • Brave I think few versions have issue not all the versions of Brave…
  • Microsoft Edge
  • Epic Privacy Browser
  • SlimBrowser
  • Torch
  • Comodo Dragon

Also, read below material by @Peter and @Enderman