Kodular hangs at "20 Establishing Secure Connection"

Right same problem with me. its hang on 20

No I use microsoft edge Chromium also Chrome

I just follow this method it works

Same problem using your tricks. also cleared browser data history cookies n all in all browser also companion app cleared reinstalled.

Try With Firefox or any other Non - Chrominium browser

May I know your internet speed and PC :desktop_computer: Specs

1 Like

I5 processor with 8GB ram and ACT fiber-net 150Mbps speed. Well now working after firefox latest update. Thank you.

Can anyone check please , is your companion working now ?
Companion stopped at after scanning qr code.It has not been working for 3 hours.

1 Like

The problem has not been solved until now

You are using the latest Chrome i guess. Use Firefox. Please next time search the community. This has been asked before.

1 Like

I use Microsoft Edge all the time. I will install and try Firefox. I searched for the subject, but it was asked a long time ago and there was no answer. Thanks Peter.

The problem was fixed when I turned the browser to firefox. Thank you very much, Peter.


I use Brave myself, no problem there also.


Now I installed it too. Thanks :slight_smile:

Very interesting. I tried 4 browsers.(Edge,Chrome,Brave and Firefox) only works on Firefox now…

I have this version
Version 1.20.110 Chromium: 88.0.4324.192 (Official Build) (64-bit)
Still working for me.

1 Like

I tried that version now. It didn’t work again. Anyway, continue with Firefox. Thank you again.

After upgrading to Brave Version 1.21.74 Chromium: 89.0.4389.72 (Official Build) (64-bit)

It no longer works. FF here i come.


Reinstalled my old version of Brave and it is working again. :grin:


I’m Try To Test my app using Kodular companion but live test stuck on 20% process I wait approx 1hours and still stuck 20% and my net speed is 200mbps

Welcome. A lot of users don’t search before asking a question. Yours was merged here. See the above reasons and fixes. Please next time search before asking.


I’m also having a problem since yesterday. I already reinstalled, I cleared the cache and it continues without advancement. I’m generating the APK at every step to check if it’s working