Kodular hangs at "20 Establishing Secure Connection"

Possible reasons.

  1. Both of them may not be in same IP
  2. Poor network
  3. Browser problem

Possible solutions

  1. Clear data and cache of companion app
  2. Check network speed
  3. If you r using latest OS, shift browser to Microsoft edge
2 Likes

Not necessary, My phone connects to a different WiFi than my laptop but everything works fine, the only thing we need is for the phone to connect to a WiFi.

1 Like

same problem with me from today

1 Like

Use In Firefox

My Working In Firfox :grin: :grin:

4 Likes

I also encountered this problem, Can’t Google’s products use Google Chrome?
It can be used when switching to Microsoft Edge.

1 Like

@Jheferson_Fonseca I also faced same.

I have a suggestion for you and it worked for me: Try connecting your both devices on the same network

Yesterday everything was right but today its stuck

To Resolve It

1. Create a empty project in kodular
2. Connect The empty project with companion
3. Open that project which you are working on
4. It will Connect

Due to

1. Too Much of blocks
2. Too much of assets
3. To much of extensions

1 Like

I am also facing the same issue. My project is brand new and also do not have any blocks or extensions. What I have is an Image component in the designer. I am using Chrome browser and testing on the same network. My device is Xiaomi Redmi Note 8.

1 Like

According to me issue is happening after release of latest chrome Version 89.0.4389.82 (Tested in some devices by upgrading and it stopped working)

5 Likes

I am also facing this since afternoon…tried every possible way but nothing worked.

Somebody from Kodular has to fix this issue asap, instead of blaming the users “oh you have too many extensions” “oh the problem is your device/project”

I’m in the middle of selecting UI colour combinations for my app and I have to install the app everytime to test colours and it’s ridiculous and painstaking.

Working 100% for me on firefox

1 Like

1 - No one from Kodular staff is blaming you with this, so YOU are blaming this;
2 - Pay attention with you account, because you have two. One of them will be silenced or deleted.

2 Likes

Mine doesnt work either. Using a Galaxy a8 2018 with android 9. Tried everything but nothing works. Also using Microsoft edge

  1. I never said Kodular staff has blamed the users, I never seen anyone from Kodular staff (except forum moderators) commenting about it. It’s the other members blaming other users and trying to put the issue on our end.

“so You are blaming this” what do you mean?

  1. I actually have 4 accounts, one on each device, to download extensions and review them.

It’s not a Kodular issue as all builders are affected by this, also it’s seems to effect all chromium based browsers, thereby use firefox

One of couple on MIT MIT App Inventor Issue (using Companion) - Bugs and Other Issues - MIT App Inventor Community

P.S. works as it should but I’m also using only Firefox

4 Likes

image

I have the same problem, and get the following errors from chrome console (win64):

Tried two different android devices with same result.
Will appreciate any help on this.

// Benjamin

Oh I thought it is Kodular and it’s companion app that is having some server issues.

Maybe I should try with Firefox.

me too. me too. me too ………