Local stored assets in Webview not displaying (AIA or APK)


(Cian O'Sullivan) #1

Describe your issue

Loaded a small png as an asset. Try to display it part of an HTML text string . An error occurs. Not allowed to load local resource file. However when you use the Get URL function with the same path, it will display. I have tried every path configuration and know the path is accurate when the GetURL function works.

This is both in AIA and APK. In APK I changed the path to ./android_assets/ and it still gave the same error.

Nothing shows up in adb logs.

Steps to reproduce the issue

Load an image asset and try to load it as part of an html.
Ensure you have the Console Messages method dumping to a label to see the error.

Expected Behaviour

Image to be rendered.

Actual Behaviour

Image is not rendered

Show your Blocks

Android version

7.0 and 8.0


How to embed media assets on a Web Viewer?
(Pablo Almeida) #2

The problem happens on android 6.0 too, using companion and apk


(Cian O'Sullivan) #3

@Kodular staff. Sorry for the shout out, but we have bee silent on this. Is this a recorded bug? Can you please let us know if we are doing something wrong, or it is a bug.

Thanks