Location sensor component(location changed) is not working

no data of location parameters are pass from the component"location changed". any help please.

Enable gps and test outside or at least clisr to a window to get a good gps signal

See also the location sensor tutorial by @SteveJG


thank for the reply.
i tried all the solutions from other topics regarding the location sensor but it did not work. it seems the component itself is not working, because i tried the variable to pass inside the location changed component but it doesnt pass anything even i pass a text message. i hope you understand what i mean. thanks again

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select “Download Blocks as Image”. You might want to use an image editor to crop etc. if required. Then post it here in the community.


blocks (3)
blocks (2)
blocks (1)
the notifier is just to test if it passes any data from the variable. but it shows empty string
thanks again

What about trying the location sensor test project from the tutorial mentioned earlier?


Also you are using the advanced version of the location sensor component, which does not make any sense


yes i have tried the samples on documentation.
but the aia cannot be imported. it needs a premium account.
the problem is i already paid my 1st month of subcription, but after 2 or 3 days it went back to free version. until now im using the free version so i cannot import the aia until the kodular fix the problem of subscription bug.
thanks again for replying.

Probably it could not be imported, because it is an App Inventor project? Import it there and rebuild the blocks in Kodular

You might want to report it here


im sorry. when im trying to import the aia file a notification pops-up. notification of paying the subscription premium. so i think components dont work if you are using only the free version. but i already paid the subscription. but after 3 days it disactivated. anywaqy. i wait for the subscription bug to be fix. And , ill try again to import and use the aia.
thanks again my friend.

hello again,
at last i able to download the aia. but there’s a runtime error " Cannot find the component LoactionSensor1". i reconstructed the thev “code” to the other project but no improvement. still it doesnt give any data from the locationsensor?
anyway having the premium version have solved some of my problems on the other project.


This happens, because the example project is an App Inventor project
Just drag a Location Sensor into the working area and repkace the component

What about providing a screenshot of your relevant blocks and do some tests outside?

hello. im sorry for late reply. i already removed the LOCATION SENSOR, and i replaced it with GOOGLE MAP component. anyway, it gives me the same data (actual location ). so my problem is solved. thank you very much, again. till the next problem :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.