Lottie crash app

Please provide 4-5 lottie links (that were not working) to check if the problem is on Kodular on somewhere else.

https://assets3.lottiefiles.com/packages/lf20_6KbrZ6.json
https://assets9.lottiefiles.com/packages/lf20_3FIGvm.json
https://assets3.lottiefiles.com/packages/lf20_4xqLHf.json
https://assets9.lottiefiles.com/packages/lf20_XhrXqc.json
https://assets6.lottiefiles.com/packages/lf20_JMptQA.json

And again, all 5 of these open in other app creators, or playstore lottie apps, only kodular error happens.

Let me check…

Hi @petrusrpenha , it seems a bug! But not every lottie behaves like this!

1 Like

hallelujah to what end you saw it is a bug!
so please see the fix as soon as possible, many use this component.

1 Like

Yea I am Also Facing This issue

any updates ? :innocent:

any updates ?

I honestly prefer kodular among many app builders, but one thing that kodular hates to want, i mean kodular support is to keep quiet about bugs, they don’t say anything, it was like when eagle was bugged in version 1.4 .0 and everyone hoping to release 1.4.1 and no one gave a due date and everyone just looks forward to it.

please lottie solution when will it come? one week ? two weeks ? 1 month ? we need dates, deadlines, after all in many cases here I am sure that people have to explain to others why creating or correcting your application is taking too long.

notice ???

I have the same problem

Post the lottie file link you’re fetching problem with.

Was having a similar problem and found this:

Apparently there may be a mismatch between the Lottiefiles (Due to optimizations) and the “player”.

If you’re using Bodymovin´, go to Export Settings > Advanced > Export old json format (for backwards compatibility)

solution ???

Hi, @petrusrpenha Lottie files issue has been solved a few days ago. Check back your project and let us know if you fetch any problem.

Sorry but it crashes still. Tried both the link and file from asset.

Not true.
Yeah we fixed it for next update.
But we did not the release yet…

3 Likes

I agree…
That’s why I made an app just to check if the lottie is working or not :joy:

Would be great :metal:

it’s still crashing my app. I used lottie files in my previous app few days and it worked perfectly but now again I’m using it for my new app then it is crashing my app as soon as it launchs… how can I fix this??? is there any old version of json files should I use on my app??

1 Like

Wait till update 1.4.3, “Solved Bugs that have been solved
See: > Bugs in Kodular Eagle

1 Like