Onesignal component not working in Fenix 1.5.2 Release

same, push notification is not working after making a new app

1 Like

How to use it?


I didn’t try enhance to connect the app to onesignal but it’s known that there is no relation between Kodular blocks and enhance. You should use one of them, not both.

1 Like


I have tried and it is really solved my issue.

  1. After you sign-in to you need to select your SDK type my suggestion is push nontification only.
  2. Upload your app by select file.
  3. Select the one signal id and enter your app id(from one signal) GCM sender id from firebase.
  4. Export your keystore file from and upload it to After you upload, you need to upload your keystore also.The keystore password is default as “android”. You can type it to blank.
  5. Check your version information and save and export your new apk from
  6. If you want to upload new apk to google play store you need to sign your apk with V1 jar and Full Apk options.

I just do it to try,
But there are lots of information you need to give them.If you have in trouble in future, it is not my responsibility… Because you are injecting a file when you use this web site. My new app size has increased 5 MB more.



Where can I locate the key store file ?

I found it from the little icon (profile) at the top right corner then went under Preferences :handshake:


Same error for me

1 Like


Did you read for above sentences ?

1 Like

Yes, I read. I really appreciate the proposed suggestion but I don’t want to use a parallel method.

I prefer to wait for the Kodular team to fix the native tool.

Hope they are aware and correct soon. Kodular is an awesome tool.


Yes, you’re right. I hope will be work again from kodular.

1 Like

Community, has this been solved, or not yet?

Not yet, ploblem still exists


didn’t understand this point.

to upload & test which method should I choose sign for testing only or don’t sign my app. if I choose don’t sign my app then I can’t test without upload?

Your app will be completely unsigned, and cannot run at all until you sign it yourself

how to sign myself?

You can test it. But you can not publish on google play store. Just you can taste it without sign.

Hello, do you have an overview of when it will be fixed? Thanks

1 Like

Same problem here. I’m new to Push notifications and OneSignal. I tried with an app uploaded to an internal test in Google Play Console and send the notifications to a tester user and the notifications never shows up.
Hope Kodular team solve this, I don’t want to envolve


No hope yet …

Many I think are using.

When can we expect OneSignal to be fixed in Kodular. Did we test Fenix 152 properly before it was released ? :slight_smile:


Upgrade to 1.5.3 but the bug is still not fixed :pensive:


In my case I also get the error at the bottom, but I see the number of users increase in the OneSignal Dashboard, which is more than the actual number.

Your user failed to be subscribed.

    Google Play services library initialization error. Check for conflicting plugins and make sure "" is in your AndroidManifest.xml. Check the logcat for more details.
    Check the adb logcat for additional errors from the device.
1 Like