Onesignal component not working in Fenix 1.5.2 Release

I don’t know how to change google play services version and I don’t know what is logcat so I asked for help.

I am sure that if sdk target in AndroidManifest.xml is 29, onesignal works properly. If I just changed sdk to 30 the problem appears

I want to tell you that I built a new app after new Kodular update and a new firebase app and a new onesignal apps and it doesn’t work. But when I decompiled the apk and changed sdk to 29 then tested again it worked properly.

So I am sure that there is something have to change in AndroidManifest.xml when sdk is 30 to allow the app to connect to onesignal.

Can you show me manifest permissions

It’s very strange that it works for some but not for others

Yes, it is very strange.

Same error for me

1 Like

Just curious, are you using Huawei phone because I’m.

Same here. After changing Target SDK from 30 to 29, Onesignal subscription is working again.
I tried it twice with two different devices (Android 11 and Android 5).
AFAIK it won’t be accepted by Play Store (as new app).
Anyone have solutions? Thank you in advance.

1 Like

for me the same thing is happening, Push stopped working :frowning: Anyone with any solution? (Detail this only occurs for new apps, I have others published that will go normal.)

1 Like

No, I don’t use Huawei

I know the solution, but many people will not like it. I integrate pushy and analytics via
Push work corret after enhance


Ok, thanks for this suggestion. If I didn’t find another solution I may use it.

Any other solutions?

Many thanks for suggesting the solution. This is only workaround at this moment.

I didn’t use enhance before this. Is it reliable?

The same problem is happening for me. OneSignal WAS working several days ago and then suddenly it stopped working as described in the posts above. I tried creating new apps and new accounts and OneSignal cannot find the app on my device. Hopefully this can be resolved soon. Thank you.

1 Like

Well I’m not sure about it’s reliability, but it provides the immediate workaround.

Same problem here , after the release FENIX 1.5.2 , has stoped working the onesignal push notifications!



Same problem here, after last update push notification component not work.

1 Like

Do I need Push notification component installed in my app, how do you think? App has enchanced twice in size :). Push worked. But Push Notification method “Get Subscription status” returns false. Seems, app worked even without Kodular component.
Hm. Component’s event works.

1 Like