Problem in sharing image after download

After downloading image I want to share it but it is not working.
It is not showing any sharing after image is downloaded.
Kindly help me in this issue.
I want to immediately share the image after download.

Tested with Companion or APK?
Companion should work. For APK you need READ / WRITE permission.
Not sure is this is asked automatically.

Try also this to get the filePath:

I tested with apk

already I allow storage permissions for downloading

Ok, then try what I suggested and post the filePath.
Connect to Companion, right mouse click on Label.Text, Do it

Tried it.
Btw It is working in companion

Then show your blocks to ask for WRITE permission.

1 Like

I have not added any permission blocks,
when download is clicked it automatically asks for permission.
Is still there need of permission block. then which permission name I will use?

No, if WRITE permission is already granted, it should work.
(WRITE permission implicitly grants READ perm.)

Just checked, for me it works.

It worked in companion but not working in apk.
Why it is not working in apk then. :face_with_head_bandage:

If it doesn’t work for you, post the aia or APK.

And a hint I received from @Boban: did you change the (default) packageName?

Yes, I have changed.

Remove it and try again if it works.

Working Now after removing package name​:face_with_thermometer:

Post the not working APK (with your own packageName), I’ll try to get it working.
I think I have the solution, but want to check it again.

Wallpapers (1).apk (7.8 MB)

Ok, I did not test your APK, but check this:

Wallpapers_2.apk (7.8 MB)

It is signed with my keystore, so you have to uninstall your app first.

When I have this simple app (shareTest.aia):


and build the APK shareTest.apk (4.8 MB) I get this line in the Manifest:

    <provider android:authorities=" de.bodymindpower.test.provider" 

If I replace it in this way the app (sharing) works: shareTest2.apk (4.8 MB)

So this issue seems to be related to this:

and this changing:

Something that @Kodular should take a look at.

Not working… same problem