Problem using blocks to request permissions

I am using the following blocks

The “ask for permission” works perfectly.
But the “Permissions Granted” and “Permission Denied” blocks don’t work at least for me.
I already tried using conditional with the “Permission Name” and it still gives the same result…

Here’s the problem I am having

permission is requested correctly


But when i click on “Allow” (PERMITIR), it is shown in the icon and color as if it had been rejected

(screenshot taken from my app)

Do any of you know how to fix it?

May be add one if then block in when permission granted and denied events as ,

If the permission name = xxxx
Then (condition)

Also during screen init set this label text and colour as null

I already tried that :pensive:
For some reason it throws me the conditional as if I had clicked on “Reject”

Please read

1 Like

Incredible, days ago it worked perfectly.
The strange thing is that the permission is given, but it is marked as rejected

Anyway, thanks Dora!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.