Problem with Write_external_storage >10

According to what I read this permission is obsolete, which makes it difficult for me to save images in Download/MyFolder.
although at the moment of requesting it, it is executed, nothing happens.


I tried several download extensions

  • ASDDownload
  • CustomDownload
  • TaiFunFile to move files and nothing. all attempts worked fine up to android 10

Maybe you should determine the android version and request:

What I need seems to be something simple, create a folder inside DOWNLOAD and host images downloaded from the url.

If you can guide me, I appreciate it

Yes, you not not need write permission, so why are you asking for that permission?

Try one solution and provide a screenshot of your relevant block and describe the issue you get…
There are several solutions just a search in the community away…


if i need permission like i said i need to create a subdirectory inside DOWNLOADS. where to save my downloads or move files from Active, on android <11 no problem.

Specifically, what I need is for the download of images to be accessible to the user, if they can be seen in the gallery it would be perfect or at least have a “MyFolderxxx” directory inside


but not use the ASD directory

You can’t store something to arbitrary directories anymore, see also Some basics on Android storage system

To see the image in the gallery, store it in shared storage and try the GalleryRefresh method from the tools extension


use this extension, Drag Download Helper extension and make use of it,

No need permission even on Android 14

you say that it is possible to create a directory in
or inside

the extensions that you use do, but on android >10 they don’t work
Permission is requested, but only works for READ

As already said earlier

What about providing a screenshot of your relevant blocks?


I know, I’ve read it a thousand times and you keep repeating it.
If there is a problem, solutions are expected.

I think I was pretty clear with the need, try all possible extensions and directories.


the download never completes or takes effect, they hang in the process with no errors.
Which does not happen in android 10 or < therefore the processes are well established.

In the extension i’ve said, just put “Download” in the download path and it works fine.

1 Like

You are asking the same questions, so it looks like you did not understand it…

Akso you still did not provide relevant blocks

Good luck with your project


Is Android 10 equivalent to Android 11? Did you check it yourself?

I tried 10 and 13