Problems with admob

How can users believe that. You can tell it, but how can they be sure? You can collect ip adresses, locations, you can save texts they are typing. And what if 2 million users at once want to try your app?

Ohh peter is on fire…:fire:

1 Like

To be honest I never thought about those things. I suppose I’ll need some kind of policy to cover those things.

That’s a good thing I suppose. Surely Firebase could handle that?

But it will cost you a lot of money. Maybe you should run you own server then. That may be cheaper.

Making my own server is too complicated for me. The idea is that ad revenue will pay Firebase costs.

I did a quick test and i saw that pressing the OK button in the message the personalized Result is set to True and pressing the Cancel button the personalized Result is set to False. So where is the problem?

The very first time I tried it it showed False when I pressed Cancel and True when I pressed Ok.

However, since then it has always shown True no matter what I choose.

I can’t see in your blocks where you call the Revoke Consent block.

I tried again and the results are the same. Works for me.

Are you using Companion or did you create apk and instal it on your phone?

Companion. I will try Apk

Are you using the blocks from post#12?

Actually i can’t try Apk because i need to request approval.

No i test my blocks

Those block didn’t work for me in the Companion or apk.

However, these blocks work perfectly in the Companion.

I will test in apk to see if they work.

I manually Load the Ad after i revoke consent that’s why it didn’t work for you but the idea is the same.

So what was the problem before? You didn’t call the Revoke Consent block?

I was revoking consent and I thought this would make the Consent dialog pop up automatically. I now realise it only pops up when an ad is loaded

I have tested on Companion and it works like it’s supposed to.

However, I created apk and it doesn’t ask me for consent at all. First apk I created I checked Consent Developer Mode and second apk I left it unchecked.

I don’t know if the apk doesn’t work because I already live in the UK

I can’t test an apk version as i said because i don’t have any app that is approved to show ads,

Hi Guys,

I guess I am almost the same initial issue, doesnt matter if I call the revokes consent function, the Persolanized.result variable stay to TRUE.

What I am doing wrong ?


Please see my blocks from post 27.

I got permission from Kodular to show ads in my app but I haven’t released the app yet.

When I create the apk I have a label in it to show if Personalised Result is true or false.

When I first open the app and select Ok it shows true. If I revoke consent then load ad it asks for consent again. If I select Cancel then the label shows False.

I have revoked consent multiple times and selected Cancel or Ok. The correct True or False result is showing up.