Runtime error while using pdf view extension by deephost and activity starter not working for viewing pdf

I am not using custom package name

1 Like

ask for permission and try again…
this works for me


I get this error when I use permission block

And for confirmation I want to tell, dft.pdf available in download folder of my device.

Your app does not add READ or WRITE_EXTERNAL_STORAGE to the Manifest.
However, you need at least one component to add these permissions to the Manifest.
Otherwise, the permissions can neither be requested nor granted:

Add e.g. the File component (as a dummy) in your app. Compile and try again.
Or add the needed permission manually to the Manifest.


Very Very Thanks to @Taifun and @bodymindpower .Now it is working :heart_eyes:. But I am confused :sweat_smile:. Whom to give a solution to? Because @Taifun helped me from the beginning to the end and I am using his logic for viewing pdf, but in the end 1 error came which @bodymindpower solved.

And thanks again to @Taifun and @bodymindpower :tada::tada::tada:

1 Like

And I want to ask one more question. Are all these problems solved?

give it to @bodymindpower

someone with an Android P device might want to test it to confirm…



Yes, I totally agree.

When I answer questions here or in the AI2 forum, then this is mainly owed Taifun, who could also help me in so many cases where no one other knew an answer.

Almost everything I know about AI2, Kodular etc. and block coding I have learned from Taifun. Without him, none of my apps would have been created and published. Of course I have learned also from others, here in this forum. Now I give something back sometimes. But the honor is due Taifun.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.