Rush • A new and improved way of building extensions

Interesting, didn’t know rush enforce naming conventions in methods.
But wouldn’t it be better if there’s a flag to ignore this? (although discouraged)

No, Rush doesn’t enforce naming conventions, it just warns you about them.

@mordechay, your build is failing because you are using an unsupported type as your simple function’s parameter type.

public void onKeyDown(int keyCode, KeyEvent event) {
                                   ^^^^^^^^

You can only use the following types as parameter or return types:

  1. String
  2. Number types like int, float, double, etc.
  3. java.util.Calendar
  4. boolean
  5. Classes of all the available AI2 components and other runtime classes, like Button, AndroidViewComponent, etc.
  6. Some other AI2 types like YailList, YailObject and YailDictionary.
  7. java.lang.Object
4 Likes

@Shreyash is there any possibility for multiple extensions in one aix any time soon?
For e.g. Custom ListView - ColinTreeListView * · Appinventor/Thunkable Extensions

cap_v7_elementHandler

1 Like
4 Likes

This post was flagged by the community and is temporarily hidden.

Hi @Shreyash , i am try to build my project without edit any thing but it doesn’t work
see this video to understand me

I’ve answered this exact issue just above your post. Please read before you ask.

2 Likes

I read it before but i did all things like install ant and add it on system path variable The same for java. i don’t know where is the problem ?

It has never been said that you need to install Ant to use Rush. Also, I’m very much sure that you haven’t installed JDK 8. At this point I’m just fed up with explaining everyone how to install JDK. If you can’t do such simple things as installing a program, I don’t think you should be developing any extensions.

7 Likes

Run this command in Powershell and post the result

java -version; javac -version

You should see something like this:

image

1 Like

Hello @Shreyash & @Xoma
Thanks for replaying me
I solved problem by add %JAVA_HOME%\bin to system variables to the path


And restart my pc … it is solved :grin:

Resources How to Set Java Path in Windows and Linux? - GeeksforGeeks

Hi Shreyash,

I installed Java on my computer.

image

And I wrote this in my extension. (removed)

And it successfully built the extension, but:

image

This block is the only block I see. Do you know where the mistake is?

I had also faced this issue.

Just re-compile the extension.

At the time of compiling this extension there was one warning in console.

"no blocks annotations "

Something like this, I haven’t remembered the warning text

2 Likes

Thanks, working now. :heart:

1 Like

getting error

[email protected] MINGW64 /e/AIX/NewDYNAMICaix/AAAAAAA/sample
$ rush build
?[94m __
_______ / /
/ / / / / / __
/ / / /
/ (
/ / / /
/
/ _
,
/
/
/ /
/

?[m?[33m• ?[mBuild initialized

?[m?[90m┌ ?[mChecking project files
?[90m│ ?[m?[36minfo?[m Checking metadata file (rush.yml)
?[90m│ ?[m?[36minfo?[m Checking AndroidManifest.xml file
?[90m└ ?[32mdone
?[m?[90m┌ ?[mCompiling sources
?[90m│ ?[m?[36minfo?[m Picked 1 source file
?[90m└ ?[31mfailed
?[m?[31m
• ?[mBuild failed ?[30;1m[?[0m?[36m0ms?[30;1m]?[0m ?[30;1m[?[0m?[30;1m]?[0m
?[m
[email protected] MINGW64 /e/AIX/NewDYNAMICaix/AAAAAAA/sample
$

done now its working

hello developers i got error when i started build with kotlin

     _______  _______/ /_
    / ___/ / / / ___/ __ \
   / /  / /_/ (__  / / / /
  /_/   \__,_/____/_/ /_/

• Build initialized

┌ Checking project files
│ info Checking metadata file (rush.yml)
│ info Checking AndroidManifest.xml file
└ done
┌ Compiling sources
│ info Picked 1 source file
│ erro src\in\sonraj\exkotlin\ExKotlin.kt:1:9: package name must be a '.'-separated identifier list
│      package in.sonraj.exkotlin
│              ^
└ failed

• Build failed [3s 212ms] [1 error]

OK sorry for this i found solution -

package `in`.sonraj.exkotlin