Send SMS issue!

I created an app that has to send SMS messages from sim card, I tried them all and it gives me the error: “Runtime Error: can only use lower 16 bits for request code”, I tried all the solutions of the forum, but nothing . also now it gives me the error “IOError: unableto create GvHelper” I think because I tried to install google voice, I can’t go forward. can you help me please?

Read this

1 Like

Thank you for replying, but I tried them, unfortunately they don’t work
IO Error: Unable to create GvHelper

When you get the error? Post a screenshot of your blocks

I accidentally ticked “Google voice enabled” to try to solve the problem I said before, and from that moment it appears to me, I searched for google voice but it is not supported in my country and I don’t have it installed

Remove Kodular’s texting component if you use it, add extension provided here While using texting component Runtime Error: can only use lower 16 bits for request code - #6 by Boban, disable Google Voice Enabled, refresh browser and see if it works

the problem is of my tablet of 2016 … I tried with an updated android and it works … why?

Does this tablet has phone and texting service in order to send messages with this texting component ?

it has a sim card module

It may have a sim module but does it have an active subscription to a provider ?

has my phone card with unlimited sms, why does it give me IO Error? since i clicked on google voice, what happened?

Uncheck google voice, Texting - Kodular Docs

despite having removed the check it still gave me the same error, so I deactivated the “Googlo voice” block even if it is not enabled and the error does not give it anymore … now the problem remains that it does not send SMS :frowning:

Are you using the extension ?

image

(where “my number” is my real phonenumber)

I took the error it generates and it says: “The permission SEND_SMS has been denied. please enable it in the settings app”

It will only work as APK and not in Companion

1 Like

while you were writing to me I tried and asked me for permission to “send sms” now a new error came out “fick null pdu-fel. meddelandet skickades inte.”
honestly I had never heard this error in my life, it comes out with a popup

Oops! actually that extension was hard coded for me only and never really got finished and I completely forgot about that

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.