SHA1 key not working

My SHA1 keystore isn’t working on firebase or google play games. On firebase, it says “string does not match a recognized certificate fingerprint format”. I checked the format and all seems good!

Have you OPT for Google signing


Yup, I opted in

And you are trying with SHA1 provided by kodular, that won’t work, you have to use SHA1 from google signing keystore


How do that find that one? I mean where can I get Google’s?

Check your console in google


Thanks for the info, problem half solved as still I am not able to sign use Google Play Games

Unfamiliar with both of them but I assume it has to do with SHA1


1 Like

Facing the same problem

This error started to appear when I deleted my previous app from this same firebase project and changed that app’s name and package name for some reason when I again tried to add that app to firebase, this error shows. What should I do now?

My app is not yet published because I haven’t finished it yet.

Maybe there is a space in the key that you accidentally copied? It shows that you key is not the format required.

No it was correct because I copied it using KeyStore Explorer so it should be correct.
That same key worked the day after. I don’t know what was the problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.