Share File With Message Beheaviour in Kodular Fenix

I do have an app that manages GPX track files with option to share those files externaly using the Sharing component.
It was working fine before Fenix release where all files where stored on the /Download directory.
Because of new file management restictions implemented in Fenix for Android 10+, i have moved all the files to the ASD.
Everything is working fine again except for file sharing.
When a share a file there is no action. I don’t get the menue to choose the app to share with as i had before.
It is not a problem with the file path because i tried several paths and, when the path is wrong, i get a file not found error but with the right path sharing does nothing.
Any idea of what can be going on here?
I’ve done deep research in the forum and the web but was not able to find any clue.
My sharing block is:


please share your blocks in english

Hi Aditja,
I’ve already added the english blocks.
Thanks for your support and best regards

1 Like

The Join block builds the path of the GPX file within the ASD.
GPX file name is “xxxxx.GPX”
It was working fine before fenix release.

I think it’s Bug With ASD in new update

You can check this thread

Bug tracker

Thanks Rohan,
I do think so but i’ve done some more research and found that it has to do with issues finding installed apps to share file with. I have tried using Taifun’s Sharing extension that allows to share directly with Whatsupp and i’m getting “Whatsapp not installed” error message.
May be this can help finding the root cause.
Thanks for your support and best regards,

Hi Rohan,
Yes, i do confirm is the same problem. If i remove the package name from the app then sharing files works as expected.
Do you know when can we expect to have a fix? I do need to keep my app package name as otherwise i won’t be able to submit updates to google play store.

I want to know what value is stored in this variable that is means show the output of this variable to me thanks

If the update is urgent and you cannot wait for a fix by Kodular, then adjust the Manifest accordingly: → <yourPackageName>.provider

<provider android: authorities = "<yourPackageName>.provider" android: exported = "false" android: grantUriPermissions = "true" android: name = "androidx.core.content.FileProvider">
             <meta-data android: name = "" android: resource = "@ xml / provider_paths" />
1 Like

Thanks Anke,
I do prefer to wait for Kodular fix. Just need to know if there is any expected schedule for it.

Thanks Adyita,
Already identified the issue. It is a problem with custom package name.
I know it is a bug that is work in progress for fixing.
Will wait for fix released.
Thanks so much for you support and best regards

1 Like

I think before Kodular has to target Android 11 (Aug 1, 2021).

That’s great news! Thanks so much!