Someone cut the power! Your apk couldn't be compiled

I tried to compile my app today 20 to 30 times . I get this error every time. Please do something on that.

You have added firebase authentication and I think you didn’t add “google_services.json” file to your assets.

You may find more information here : ReadHere

Read the dialog shown when you use that component…

Hope it helped


show ur view log screenshot

your json file have the wrong package name. Or you didnt put the file into the asset foler. This problem happend if you use firebase auth.
You app package name and the package name in firebase google auth have to be the same, or you get the error. So please check if you have the right name in both part.

I have the same problem
I have the correct package name, the file google-services.json in assets and everything as it says it should be, and when I hit a button that invokes the event Sign in with google, nothing happens.

I have everything configured as suggested and still does not work…

Have you whitelisted your client ID?

This will not work in companion, you have to built the apk and test it there.

I whitelisted my client id…
I Built the apk and i test it and doesn’t work…
I will continue testing…

Google do not work for me to. The Login failed Component triggers. If you read my post from yesterday you can see what works,
It looks like as the google component make only a login and no sign up, I test it for a while and i use almost all components to see what works and what not. And i think with google sign in component you cannot make something wrong. A button what do start the google sign in Component.

If you try it with the email component, did you get toast msg from firfebase? I wanted to know if you get the same. If i login in success i get a bottom toast with: Login Success Success. I think one Success is too much.

If I try with email and password sign up, doesn´t work. I get a message saying:

"The given sign-in provider is disabled for this Firebase project. Enable it in the Firebase console, under the sign-in method tab of the Auth section "

And I have activated the option for registration with email and password

you have to do this in your builded apk, in companion this wont not work. And please remember that this is not your post, pls make your own post, because if people have the same problem they may look for that and so they can find help.
But i gave you the answer in the last posts, did you not read that?

If we make 20 post with the same problem these is a mess, so I share it here, to see that there are several of us who have the same problem … If you have the same problem you can consult in one place … isn’t it better?
If the administrators see it wrong, delete my messages, no problem …

I’ve tried everything and it doesn’t work.
Your solution doesn’t work… (( and your English is as bad as mine… hahaha!!! :rofl::rofl::rofl::rofl::rofl: ))

If your emal and passwort sign up component did not work, than you did something wrong. Google sign in do not work in companion app and in your builded APK. The Email/Password Sign in and Login should work. ( for me it works) Your Package Name have to be the same, in your APK and in the google json file.
If you did all things like i told youi above and if you did all the stelps what the team wrote in the tuturial docs, than it should work.

For me and all other people here, it works to sign up and login with email and password, Google sign in do not work.

1 Like