Stack Size 8Mb error

Hello friends
I am facing stack size 8MB error everytime. I have change all block but error doesn’t solve.
I didn’t use any extension in my app. I have search Google and Kodular Community but I didn’t get any solution.

Screenshot of error

Are you sure you have searched the community? This :point_down: is what I got when I searched the community

Tip: Read the whole topic for the solution

I have tried that solution and use my app in different devices but problem doesn’t solve.

But if you read the quoted topic there, you will come to know the user had a procedure which was calling itself. Maybe that would be your problem?


you created an endless loop


I have not use Taifun extension

We didn’t say you are using Taifun’s extension :sweat_smile:

So what I have to do to solve this problem.This problem occurs when I monetized my app.

Taifun answered. Remove all endless loops.

Also, what do you mean by monetize app? You mean AdMob etc. or making earning app?

What is mean by endless loop & monetized means placing ads in the app.

Do you used for, foreach, while in your code or any block which can repeat? If yes, looks like there is no end of loop in your blocks. So this will cause endless loop and your app can’t handle it, so it giving this error.

I am using block
when screen initialized- load banner ad
When banner ad loaded banner- banner ad visible to true
When banner ad failed to load - load banner ad

Did you try using different ad network? Or you can try to only set ad load/show blocks under Screen.Initialize.

Yes, I loaded ads when screen initializes
Banner ads

Can you show your blocks which causing this error?


App didn’t show this error when I remove all types of ads from my app

Look, Clock2 is working every second and it loading ad in per second. So this will make your app laggy. Then finally, it giving this error.

Disable your clock after ad loaded.

No I have remove clock2 and interstitial ads and try app but shows same error

Did you try this?

Just add Clock2.Timer Enabled = false in Clock2.Timer event.

I didn’t understand this