SurfaceView not working after Fenix Update

I was notified of an update to Kodular this morning with many updates and improvements. When I run my current app using surfaceview I am presented with a blank white background instead of the camera view. Is this a bug in the update, or do I need make a change in my blocks? I have recreated the block with new copies of the surfaceview blocks, and I have also tried adding the blocks shown below. Finally I removed all reference to Image2 and simply called the SurfaceView to open, and it does not open.

Thanks for any help.

Did you set your image.visible to false?
Did you try to change screenorientation to the opposite and visa? This may help.

Thanks for the reply. I removed the image entirely and only called it to open SurfaceView. I addition, created a new app that only opens SurfaceView when a button is clicked. When the button is clicked nothing happens. Since your suggestion I tried both Screen 1 orientations with the same results. I have run the test app in Companion, as well as, created, downloaded and run an APK. None of them open/start the SurfaceView. I believe it an issue with the new version release.

1 Like

Then it seems to be a bug here. I am on holiday so I can’t run tests myself.

Has this been officially reported as a bug? If not how do I get it added to the queue. There is a list on a community post titled “Kodular Fenix Bug Tracker” and it is not on it.

Not sure about whether it is reported or not but it has bug. Fenix with surface view exten

Is your problem is solved? Because I have same issue​:sleepy:

SurfaceView is working fine under Android 7 as before. I just tested it.

I created an app that only opens SurfaceView. It still does not work in companon or as an apk on Andriod 8.1. Did you create your apk since the introduction of Fenix 1.5? If so, what did you do to get it to work?

I have an extension agoraRTC, not working after the Fenix update, in which i used SurfaceView. It,s working on Mit server.

I have also problems with surfaceView.
It worked well before the fenix update.

I have 2 floatbuttons on SV. If both of them are visible, i see this; It shows till the floatbutton.

When I make the buttons unvisible;

1 Like

@Vishwas why isn’t this present among bugs in bug tracker? This is a serious problem that have to be fixed ASAP

1 Like

Really strange that none of the betatesters picked that up when it was time to test. Or didn’t the betatesters test? Maybe we would have had fewer problems now.


Hi everyone !

Well, same issue that Michael_Lee_Corley described :
works fine before Fenix Update on Android 10.

But now, only shows white screen, no preview (even if the take picture event works). The blocks are very simple…


Try to change orientation, make some property changes but with no result.

Try this one surface.aia (2.3 KB)

1 Like


This aia works perfectly.

It seems that the component SurfaceView have to be fullscreen with no other component on screen, even Title, Statutbar, Button… (Floating button creates a white stripe)

In this case, impossible to do on screen preview. Ok another challenge !

Thank you for this solution, hoping this “issue” should be fixed soon.

This post was flagged by the community and is temporarily hidden.

1 Like

OK so its still work if you send the preview to canvas component… but the framerate so so… it much better if the picture shown on it self…
but that much better for fast fixing, than waiting the kodular fix this bug… if you has urgent project like mine…just imagine that an “engineer’s tape” lol

This is not listed on the “Kodular Fenix Bug Tracker”. Is this bug going to be fixed?

it still works, but you need to “Unvisible” almost anything… and put the surface view on top everything on the screen… and that will made your overlay didnt works anymore… that sad…