The operation Picture cannot accept the arguments: , [*nothing*]

I’m trying to show an image in the image component through the Image Picker. When I select an image from my cell phone: “Select a photo” this message appears. When I select from a folder for example: camera, instagram, Photo Editor it accepts. Can you tell me why?

image

Images that give error when selected:

Images that appear when selected:

Hello @Carlos_Alberto_Leonel

I think this problem occurs because of your phone setting. I am not sure. Can you disclose the full block area pic. If Then I could help you?

Problem due to android version , try to join the block file:// in front of get selectiin

Selection path is empty or null. So joining file:// to a null path doesn’t gonna be worked.

Yea, @Sumit1334 I am also agree with you?
The Fill:// will not work.!

So I’ve already done this:
join: file:// + getselection and gives the same error.

Yes, This will not work…

Can you please disclose the all blocks you have set for this operation! :no_mouth:

But if the setting because it lets you select images from the camera?

Android version ? Also temporarily add a label and when image picker, after picking, set label to get selection and post the result here

Yea? That’s why I am asking for the blocks or the aia if possible.

Otherwise you can try what @dora_paz said… | But @Carlos_Alberto_Leonel is using Google Photos & the Google Photos version may be the recent one so his device was may be have Latest Android.

imagem_picker.aia (27.5 KB)

I did something very simple. When I click on Dismiss nothing appears in the label

Android Version: 9

Found the Problem

Problem with Image Picker, Let me fix this? Wait a Min…

Do you need the solution… :joy:

Go to Image Picker >> & Add a Text Value
Go to Screen1 >> Fill all the details Like ( Title, ete etc Make sure that are not blanked, If you don’t want to add any text then try using a SPACE )

It working…

If this works then Please mark this as Solution. Thanks

This is not a solution. Tested provided aia on Xiaomi Mi A1 android 9, companion and apk, runs perfect, could not replicate error.

Then I guessed the problem is in the phone setting

One question, Does Image Picker automatically ask for permissions. May be Not? He have to set this I think…

One more thing check with another image…

Also try to test same image with activity starter. Does error occurs or not ?

So it worked. Now how do I save this image in firebase storage and then show it in another image component? When I do this without using Activity, doing that process that gave an error, I get the “selection” I store in storage and then in “Upload Success” I get the url and save it in Firebase Database. How Activity would look like?

1 Like

Is this related to Save to Firebase Database the url of the image or text stored in Firebase Storage?

So the problem is in Image Picker that due to this problem I can’t select an image from the photo gallery, just for camera. You showed another alternative which would be the Activity Stater. I want to create a portfolio of my professional, that is, he will add at least 6 images of work he has already done, save to the cloud (Firebase Storage) so that his client can see them later. It’s like a business card, but only with images.
I already know how to save the images in firebase storage and get the url to save in the database. With Activity Starter if I put the Result URI in the Firebase Storage upload file it doesn’t accept.
Anyway, if I solved the imagepicker problem I wouldn’t need to go here to ask for help.

Dora, if it’s too complicated, I’ll give the professional the option to just take a picture and store it on Storage. It would be interesting if he could select the images but as it’s giving an error, I’m going to abandon the idea