Unable to compile AAB

i am able to compile my app to apk but when i tries to Export AAB it shows build failed

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/..
________Creating listview xml in res/layout-v21/..
________Creating xml in res/drawable/..
________Creating splash png in res/drawable/..
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________________Firebase components found.
________________Firebase config file successfully added.
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT2 compile time: 0.466 seconds
AAPT2 link time: 0.557 seconds
________Compiling source files
(compiling io/kodular/inboxofprakash/AHEN_UserApp/Authentication.yail to io.kodular.inboxofprakash.AHEN_UserApp.Authentication)
(compiling io/kodular/inboxofprakash/AHEN_UserApp/Screen1.yail to io.kodular.inboxofprakash.AHEN_UserApp.Screen1)
(compiling io/kodular/inboxofprakash/AHEN_UserApp/ErrorScreen.yail to io.kodular.inboxofprakash.AHEN_UserApp.ErrorScreen)
(compiling io/kodular/inboxofprakash/AHEN_UserApp/Info.yail to io.kodular.inboxofprakash.AHEN_UserApp.Info)
(compiling io/kodular/inboxofprakash/AHEN_UserApp/Booking.yail to io.kodular.inboxofprakash.AHEN_UserApp.Booking)
(compiling /tmp/runtime2392654681311821248.scm to com.google.youngandroid.runtime)
Kawa compile time: 2.403 seconds
________Invoking DX
DX time: 6.5 seconds
___________Creating structure
___________Extracting protobuf resources
________Running bundletool
________Signing bundle
.

Try by rebuilding again after you get that error…

tried so many times

No one is responding​:pleading_face::pleading_face:

Already added, try to rebuild

If not please make sure you have added your app package name in settings page.

1 Like

it was not working from two days but today it worked thanks