Unable to download apk

Hi to the community.

Being new to kodular (moved from AppyBuilder) could anyone please help in this problem I face with my first project?

When I simulate my app using Test|Connect to Companion all goes well.
When trying to dowload apk in my phone using Export|Generate QR code for app, I am getting the message “Scan QR code on your phone to install the app”, then I am driven to the home page c.Kodular.io . No link to download the apk file.

Version of kodular companion is 1.4 Eagle.
My device Samsung SM-A310F
OS Nougat 7.0 API level 24, no rooting

I tried all suggestions found in Unable to download application by scanning QR code
Error download apk file
such as

  • restart phone
  • unistall/reinstall kodular companion
  • allow unknown sources
  • change package name to com.nf.TriTriliza or com.google.TriTriliza (project name being TriTriliza)
  • no assets yet

I suppose the error is hidden in package name (?)

Could you propose something more?
Thank you.

Scan Qr Code from companion after that it redirects you to browser with download link.
Link is copy in clipboard if download doesn’t start then paste link again

1 Like

In my case i have to close all the tabs of google chrome before i scan the qr code otherwise the download doesn’t start. Maybe you should try the same.


same for me just do it twice means, after browser loads but download not started then on url tab click you will get option that copy link from clipboard which is app link simply click on it then it starts downloading.
if there is no link in clipboard then scan qr code again

How the Package Name must be filled?
I suppose com.AnythingILike.ProjectName . Is that correct? In the middle part I put my initials.

Didn’t work. It shows the entry page of kodular. Thanks anyway.

What happens when you create a new project (eg just one button), will the APK / QR code be created?
If so, there is a issue with your recent project.

I created a simple project (just one button and count clicks). It is also unable to create APK/QR code. test.aia is attached.test.aia (1.8 KB)

Which browser? Try another: Firefox / Chrome

I work mainly with chrome (v. 78). I also tried Firefox with same negative results. Could ypu please check if Package Name (=com.nf.test) is valid?

Ok, then it should probably be a network problem, try it on another PC and / or in another network.

1 Like

Thank you. I will try this way.

Yes, and also try to disable anti-virus software, firewall, … temporarily

Tried in a laptop in the same network unblocked the downloading error. Then dowloading was well performed in the former pc. Problem resolved. Thanks @bodymindpower Anke.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.